Cannot add animations to button states, graphic changes size

Hi -

Two issues going on, tested in both SL3 and 360.

I have a simple rectangle with text that is a button with a hover and a visited state. In the edit state mode, I select the rectangle in the visited state but the animations ribbon is grayed out - I cannot add an animation unless I delete the rectangle and paste a new one into that state. 

This works, but then another issue arises. The visited state graphic displays smaller than the other states, even though the dimensions and position are exactly the same and it looks correct when editing. 

Ideas? See attached images. 

Thank you.

 

 

 

 

10 Replies
Candice Pitman

I can't give an official reply on why this is happening, but I can say that it happened to me on a recent project. It happened when I adjusted the size of my item and then made changes to the hover/selected state - it would glitch out the size on hover/select. 

My solution was to remove the item, add it back in, make my edits to the hover/selected state, then resize the item as needed. After that everything worked perfectly. 

Perhaps something like this would work for your project? Best of luck!  

Amy Nicholson

Thanks Candice. I did just read somewhere that in order to add animation to a state I must cut the graphic (that is auto generated from currently selected state) and paste it back. So yes, that allows me to create the animation. Somehow though the graphic is smaller. I now have it set to disabled when the user clicks so at least they don't see the larger hover graphic sticking out behind it. The disabled state is smaller but not that big a deal now. Still odd and I would still like to figure out what they hey is going on. But I think I have a work around for now. Thanks!

Ren Gomez

Hi Amy,

Thanks for sharing those images, and I'm glad you were able to find a workaround on the resizing issue for now.

If you continue to have difficulty you may also want to conduct a repair of Storyline 360 Also, please feel free to share the file with our Support team who can help determine if there is something else happening. 

Amy Nicholson

Hi Ren - Thank you for the feedback. I also have SL 3 and found that I have the same issue. Seems odd that both would have it if it's a repair issue, don't you think? But if this is a possibility, I will repair. 

I'm also getting odd things like when I cut the graphic from the button state and then re-paste (so that I can add animation to the state) the graphic comes in without any fill or border. I must manually add the fill back in (and sometimes that doesn't work as well, sometimes it does). Oddities. 

In the past when I wanted animation on a button state I would use layers but having it as part of the button is a lot easier, if it works. :-) 

Amy Nicholson

Hi again. I have found the problem. (I did a reinstall as you suggested but that did not help.) 

The animation I was using is a swivel at .25 seconds. When I changed it to .5 seconds, the problem (of the image changing size) went away. Almost as if the .25 was not enough time for the image to "swivel" to it's full size (it would appear a bit smaller than the original).

The other problem is not a big deal (right now!) - when I cut and paste into the visited or selected state (in order to create the animation) the image (a rectangle shape) comes in with no fill and no outline. The text is there, as is the shape (with dotted lines to denote). Odd, but easily fixed. 

FYI, I have now tried the .25 seconds setting with other animation styles (e.g., grow) and they work fine. It's only the swivel animation that was a problem. Of course, that was the one I was using. 

All good now, but perhaps someone can report this as a bug? 

Vincent Scoma

Hey Amy,

Thank you for providing that context of what you are seeing! I am glad to hear that you found a workflow that helped! 

I tried to replicate the issue you are seeing but I wasn't able to get the same results. May I ask if you could share a screen recording of the issues you are seeing? That would help out greatly in pinpointing what this issue might be. 😄Also, does this seems to happen in just one course or all of your courses?

If you have any additional questions on this, please let us know! 

Vincent Scoma

Hi Amy,

Thank you so much for sharing a video of what you are seeing! 

I followed the same workflow in the video and I was able to recreate what you are seeing. I am reaching out to our team about this behavior and opening a case for you to share any additional details with our Support Engineers. I will include everything you have shared in this thread in the case as well. You should be a receiving an email soon from Articulate Support! 

Please let me know if you have any other questions!