Cannot preview/publish storyline project

I am sure you get tired of answering these as I see I am not the only one having this issue from time to time.  Like so many others I am on an extremely tight time schedule and until now had no issues being able to preview or publish my projects.  For some reason I can only preview the first four slides of my project and nothing else.  I need help!!!  Thank you kindly!!!

Sarah

16 Replies
Peter Anderson

Thanks for attaching the .story file, Sarah. Unfortunately, I'm not able to load the preview after slide 6 either, even after importing it into a new file. There seems to be something weird going on with that particular slide. At this point, I'd recommend opening a ticket with our support team and they'll be able to take a closer look and offer you some quick help to get this resolved. On the second page of this support link, you'll be able to send them your project. 

Thanks, and good luck with the course

Sarah Noll Wilson

Thanks for taking a look at it Peter, I really appreciate it!  I went back in and completely deleted the slides 5-6 and then the entire project worked.  So now I have to figure out what corrupted those slides as I still need them in my project.  I'll be sure to update you when I figure it out or support does so others can learn from it   Thank you again!!!!


Sarah

Peter Anderson

Thanks for checking back in, Sarah Yeah, I agree. Knowing which slides aren't working is half the battle, but it's also always good to know how you can prevent the same thing from happening in the future. Here's an article that has some tips that may help with that. 

Good luck with the project, and I'll look forward to hearing your success story!

Eric Nalian

Hey Sarah!

Is this the infamous 'slide 6'

Here is something kooky - you get an error message upon previewing if you delete one of the triggers that moves the character:

ERROR: Could not load the file 'C:\Users\eric.nalian\AppData\Local\Temp\Articulate\Storyline\6OaYwB5zmWL\Preview\story_content/data.xml'

If you remove the character all together, you can preview all the slides..

I hope this helps diagnose the problem

Sarah Noll Wilson

Thanks for looking into that Eric.  I discovered when I deleted the whole slide it worked.  Can I ask, since I am new to this system, where did you see the error?  That would be helpful if I run into this again in the future.  Now to figure out how to achieve something similar without breaking the system

Eric Nalian

I got that error when I clicked on preview.  It was discovered by process of elimination - I deleted an object, previewed, undo change, delete, preview, undo change...repeat until the entire project would preview.

When I deleted the character, i was able to view the entire project.  When I deleted one of the triggers that made her move, I received an error.

What if you delete the character, delete the triggers and then rebuild the interaction.

I noticed something was off with the character when I clicked on her and the box with the re-size handles was not surrounding her...

Sarah Bennett

Hi, I know this post is a few years old but I thought I'd add a comment for anyone else that has issues previewing and publishing projects and stumbles across this post (as I did). I had the same issue with a project and it was driving me crazy. I've only just realised that when you get the error report dialogue box come up, if you click on the hyperlink that says "information" you will be able to see some details that can point you in the right direction for detecting the problem. I've just found out that Storyline 2 doesn't like the font 'ITC Franklin Gothic Med' so this is what has been causing me issues! Not great considering that's one of our company's official brand styles but hey ho, I'm sure I can find a similar one!

L Q

I'm having the same issue. I cant preview or publish. The error message is below. Any advice? :

 

<?xml version="1.0" encoding="utf-16"?>
<ErrorReport xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<FirstName />
<LastName />
<EmailAddress />
<MachineName></MachineName>
<HardwareId>2PQ02-F1SG0-U4UUV-T3DVJ</HardwareId>
<Message>TimeSpan does not accept floating point Not-a-Number values.</Message>
<StackTrace> at System.TimeSpan.Interval(Double value, Int32 scale)
at hk.g()
at hk..ctor(Shape A_0)
at Articulate.Design.Shape.AddPlayerEventsCore(IPlayerService service, IPlayerTimeline timeLine, bwStageObject stageObj)
at Articulate.Design.Shape.Articulate.Player.IPlayerShape.AddPlayerEvents(IPlayerService service, IPlayerTimeline timeLine, bwStageObject stageObj)
at Articulate.Player.PlayerContentPublisher.a(IEnumerable`1 A_0, bwSlideBase A_1)
at Articulate.Player.PlayerContentPublisher.CreateSlideObject(IPlayerSlide slide, bwISlideContainer sceneobj)
at Articulate.Player.PlayerContentPublisher.CreateBridgewaterSlide(PlayerWriterSettings settings, IPlayerSlide slide, bwISlideContainer sceneobj)
at Articulate.Player.PlayerContentPublisher.CreateContentScenes(PlayerWriterSettings settings, IPlayerContentProvider contentProvider)
at Articulate.Player.PlayerWriter.WriteContent(IPlayerContentProvider contentProvider, Nullable`1 merged)
at Articulate.Player.PlayerWriter.Write(IPlayerContentProvider contentProvider)
at Articulate.Design.Publish.TargetContext.PublishBackgroundWorker.OnDoWork(DoWorkEventArgs e)
at Articulate.ComponentModel.STABackgroundWorker.a(Object A_0)</StackTrace>
</ErrorReport>

Leslie McKerchie

Hello Lee and welcome to E-Learning Heroes :)

I've seen another user report a similar issue here.

I took a look at the case filed in that instance and the culprit was grouped objects that were not represented on the timeline.

If you can pinpoint the slide(s) that are not previewing for you, you should be able to identify and correct these objects. 

Hope that helps.

If you need our team to take a look, you can share the .story file.