cmi.success_status set to "unknown" when test failed

Hi all. Bit of a strange SCORM2004 question here. 

My LMS (corporate built) uses cmi.success_status to generate a failed/passed result for the user. 

With my SL2 course set to Passed/Incomplete, and the results of a test results slide being used for course evaluation, I've notice that my course returns an "unknown" result to the LMS whenever the test is failed, instead of a "failed". This seems to stop the LMS from displaying the actual test score, which I want displayed. 

The test score is displayed and "passed" state set in the LMS whenever the test is passed. 

I want to use the Passed/Incomplete publishing option as it prevents a "done" status in the LMS from being set to "done" until the test is actually passed.

Anyone know how to force my course to send a cmi.success_status "failed" instead of the current "unknown" when the test is failed?

Thanks. Link to the SCORM_CLOUD log of this course (failed) is below. Cheers.

https://cloud.scorm.com/sc/guest/ViewDebugLog?logId=226afd1e-730a-4e9b-bfc7-b3cd80fb183d&courseTitle=Driving+Safety+Systems%2C+Steering+%26+Suspension+Pre-study 

 

3 Replies
Alyssa Gomez

Hi Steven! It looks like you've already done some troubleshooting on your own via SCORM Could. Since you've got the SCORM Cloud log, I would recommend reaching out to our support engineers as a next step. They're really experienced in working with LMS reporting errors, so you'll be in good hands there. And if you want to share your case number here, I'll be able to follow along and post updates as they're available!

In the mean time, you may want to check out these steps for troubleshooting LMS issues, in case you haven't seen it already. In that article, you'll find more information about the four pairs of values that can be reported to an LMS.