Communication Issues When Using HTTPS With relay.asp

We publish/run AICC courses from our SumTotal LMS. LMS is on one server in one domain, our content is on another server in another domain, all within our enterprise. We have been using relay.asp as our launch file for several years with great success.

We were recently told that we have to use HTTPS rather than HTTP, and that is causing us problems. Dropped completions, total absence of bookmarking functionality (no ‘resume’ dialog, courses just start over again).

  • HTTP and relay.asp = everything works fine.
  • HTTPS and relay.asp = dropped completion messages, bookmarking nonexistent.

What interaction/interference would there be between using HTTPS and the use of relay.asp?

16 Replies
Bob Wiker

Thanks. Hopefully someone with knowledge of HTTP vs HTTPS can chime in.

If anyone out there can give a technical explanation of what relay.asp is doing that would be great, and may give me insight that helps solve our issue. I know it's for cross-domain security handling, and I've looked at the file's ASP scripting, but I'm still a bit stumped. Thx in advance.

Bob Wiker

Good news: Yes, I'm still subscribed to this item.

Bad news: I never got a reply from anyone. HTTPS and relay.asp remained an issue.  Until...

Information: Without notifying our team, the corporate IT department (think Mordac from Dilbert) put a cross domain file at the root level of each server volume; it is an XML file. See attached screenshot. They later told us to stop using relay.asp because it was causing problems for another business unit within the enterprise (no details or explanation, of course). So, we ultimately ended up using https:// in our URLs and pointed directly to the index_lms.html file of a course, and relied on the cross domain.xml file to do its thing. It worked. Hope this helps; search the Internet for more info on cross domain.xml  Cross domain XML file

Ashley Terwilliger

Hi Meena,

When publishing for LMS, if your LMS does recommend pointing to a specific link/file we do recommend the index_lms.html . As far as bookmarking you'll want to ensure you've set the resume behavior as detailed here and then depending on the LMS, do one of the following:

  • If your LMS supports bookmarking, mark the box labeled When running in LMS, ignore Flash cookie. The LMS will control resume behavior in this scenario.
  • If your LMS doesn't support bookmarking, uncheck When running in LMS, ignore Flash cookie. A Flash cookie on learners' computers will control resume behavior in this scenario.  (Note: if the user changes computer or clears the browser cache, the resume will be reset).

Let us know if you need further clarification! 

Bob Wiker

Yes, everything worked: launch, suspend, resume (with bookmarking), completion.  Using HTTPS, the cross domain.xml file, and launching to index_lms.html.

Needless to say, though, there are other factors that could well be the source of your issue(s)--the LMS you're using, how it's configured, how your network/intranet is configured (domains, volumes, whatnot). All of those are beyond my expertise, and as I mentioned earlier in this thread our IT department was an opaque organization staffed by Mordac the Preventer of Information Services (from the Dilbert comic) so we never really knew what we were dealing with(!).

Ashley Terwilliger
Bob Wiker

as I mentioned earlier in this thread our IT department was an opaque organization staffed by Mordac the Preventer of Information Services (from the Dilbert comic) so we never really knew what we were dealing with(!).

Laughed out loud at this Bob... now does your IT Department know you refer to them as such? Remember this is a public forum. ;-) 

Meena Bathia

Ashley,

LMS does support bookmarking so we have "When running in LMS, ignore Flash cookie" checked. Using both IE and Chromes developer tools we can see the following:

When the course is launched for the first time and after viewing few slides when we exit the course sends putparam command with the bookmark information. When we launch the course again, we can see the course sending getparam command and LMS responding with the bookmark information. However, the course does not display the resume prompt and takes us to the beginning of the course.

LMS is responding correctly so what else can we do to resolve this issue?

Ashley Terwilliger

Hi Meena,

Thanks for sharing that additional information. Have you also double checked running it in SCORM Cloud to see if the behavior is different? That's an industry standard for LMS testing, so double checking there will help narrow down where the issue lies, and this article will walk you through how to test. Additionally you could look at enabling LMS debug mode and compare that with your developer tools console within your LMS and SCORM Cloud.  If the same behavior persists in SCORM Cloud, we'll want to take a look at your .story file to see how everything is set up and you can send it along to our Support engineers here. 

Ashley Terwilliger

Thanks Meena and I see you're working with Robert on this case and he's done some additional testing of your course with AICC and testing at SCORM Cloud. I missed in this thread that you were using AICC to publish - and when testing in SCORM Cloud you'll want to ensure you use the method outlined here to update the published output. I

Robert shared a sample couple of your output and a link to the course within SCORM Cloud for you to test out - so let me know how that version works for you and if you need anything else!