Course Content Not Displaying on iPhone

Hello! I am new to Storyline 2 and working with my first LMS implementation. We are attempting to publish courses (very basic - read slides and take a quiz) and make them available to our users on their mobile devices in addition to at their desks. We have played around with a lot of the settings based on various threads we've read, but I haven't yet found a combination that works correctly. We can get the courses to launch just fine on android devices, but on iOS devices the player will load fine, the buttons work and as the user advances we can see that it's advancing in the menu, but the actual content area is blank.

We've tried uploading a sample course to scorm cloud, but there we are experiencing this same issue on both iOS and android devices.

Here's what how we're publishing currently:

  • In the player settings we've gotten the closest by choosing "Resize browser to optimal size" and "Lock player at optimal size" with the "Launch player in a new window..." option deselected.
  • When publishing we are publishing for LMS and selecting the "Include HTML5 output" option and deselecting the option to "Use Articulate Mobile Player for iOS or Android"
  • We are currently publishing for SCORM 1.2 (2004 adds some very unattractive html code to the player window in our LMS). Tin Can is not supported by our LMS.

Any help would be greatly appreciated!

13 Replies
Kelly Benzschawel

We've tried both Safari and Chrome. We'll check those settings for popups and cookies - that could definitely indicate why we would be having issues with the SCORM Cloud version on the android device.

The course does look good on a desktop and on an android device through our LMS's mobile app.

Mike B.

I just tested this on our iPad and it seemed to work fine, looked just like it did on my desktop. I even uploaded it to SCORM Cloud and it worked the same there. The only odd thing I noticed was that I had to un-check support for the Articulate Mobile Player when I published. I thought that setting got saved into the project file, but maybe not. Also, I got a message when running through SCORM Cloud that it was trying to open a popup window, which I allowed.

Are you saying that the area inside your slide, i.e. where is reads "Practice Course" on slide 1.1. is blank?

Mike B.

I received your invite, and I see what you mean now. :)

Yes, the slide contents are blank for me when viewing the course you published on our iPad here. I'm not sure if this is a publishing problem or what. Are you running the most recent update of Storyline? Have you tried a new 1-slide test course to see if it behaves the same way? You may need to contact support on this one.

Ashley Terwilliger

Hi Kelly,

I'm glad to see Mike has been able to help you test today - and it looks like when he republished the course and uploaded it worked normally, so if you're published output isn't behaving I'd also look to confirm that you're using the latest update of Storyline 2 Update 7, and you can download it here to republish with that.  If you're still having difficulty and it's replicated outside this one file as well, I think we'd need to know a bit more about where you're publishing (ensure it's to a local drive) and then any additional steps you've taken in terms of the upload.