Course Navigation Problems

Help! I just released a course that has triggers setup to disable the next button until the learners have clicked all topics. I'm having a large number of users who are stuck and can't proceed even when they click everything that should trigger the next button to change back to normal.

I am curious if the users are timing out or if it has to do with using the back button. Any help or advice on how I can apply a quick fix would be greatly appreciated!!

7 Replies
Marley Lustig

This seems to be the slide causing all the trouble. The trigger is set to change the state of the next button to disabled until the state of all objects are visited. I'd like to keep the restrictions in there but so many people are having trouble I'm thinking I might have to republish without the restrictions.

Thanks in advance for any advice!

Crystal Horn

Hi Marley!  Thanks for sharing your .story file.  I had a look at slide 10 and made some minor changes.

When building a trigger, it can be tricky to use the action "when state of X, Y and Z are visited."  I find it to be a bit more reliable to use a trigger based on a user click or when the timeline starts.  With that in mind, I made the following changes:

  • I changed the trigger to change the Next button to Normal to fire when the timeline starts, and I added conditions to it.  I also added conditions to the trigger to disable or hide the Next button:
  • I changed the triggers on the layer to jump back to the slide, rather than "Hide this layer," because I want the slide timeline to start over when they leave the layer:

Your Next button should reliably hide and show under those conditions.  I'm attaching the modified file.  Let me know if that works for you!