Course stuck when revieweing quiz?

Hi,
I've stumbled upon a possible bug, where a user is presented with a quiz, followed by normal slides. If a user answers the quiz, but hits the "back" button on the following content-slides, the user will be able to review the answers he just made. (even though I've disabled the previous/next buttons for the question slides). Most of the time, this works fine. But sometimes it gets stuck when reviewing a question. There are no "prev/next" button, only a "submit". But the answer is already submitted and selected, so the user is stuck with no other option than to close the course and start all over again.

How would I prevent this problem?

17 Replies
Susi B

Hi Stian,

you could activate a pev/next button as soon as the question is submitted so they can jump back and forth. They cannot retake the quiz right? And maybe they are stuck because your quiz slide is not saving right. Did you choose your slide properties to automatically decide what happens when the user comes back to this slide or resume to saved state? Does it advance by user or automaticalle? See this article.

Greetings,

Susi

Stian Larsen

Hi, and thanks for your reply. Yes, that might be an option. But, activating a prev/next button is only helpful if the slide remembers it's state. And I think that might be the problem here.

It's weird, because the slide remembers the answer, but shows the "submit" button, and not "prev/next". Nothing happens when clicking submit, and the user is stuck.

Slide properties are set to automatically decide. problem must be the way storyline advances, before it manages to save the state completely? If so, this is a bug.

Since my problem is that the slide does not remember all settings upon revisiting, enabling a prev/next button is also doomed to fail, because I rely on storyline to remember that I actually enabled these buttons after submitting. And if it does remember, I wouldn't have this problem in the first place?

Susi B

Hey Stian,

could you try to change your slide properties to "resume to saved state" and advance "by user" and test it again? Maybe this already solves your problem. And do you test it online on your LMS or only locally on your PC?

You could also test it in Scorm Cloud which is recommended by the staff many times. If nothing works you can still submit a support case here or attach your file in this post so someone else could take a look into it if it´s not confidential content.

Greetings,

Susi

Stian Larsen

I'm getting this problem when testing in our LMS. Have not tried it locally yet. I did make a small test to try and reproduce it locally, but so far it's not breaking apart.

Not sure what would cause the slide to only save some of the properties, like which answers is checked, but still showing the submit button when revisiting, as if the question was not answered.

I will upload to Scorm cloud to try and reproduce the error there, with a new simple course. I'll report back after trying your advices. :)

Susi B

As I said please change when revisiting to "resume saved state", with this you force storyline to save the slide at the state the user leaves it and test your course/slides again if they now behave the way you want them to. :)

And don´t worry about your flagged post, this happens when you post to fast multiple answers in the forum.

Stian Larsen

Sure, that's what I'm going to try. But the course I'm having problems with is quite huge, so I wanted to try and reproduce the problem with a smaller test-course first, and then try and fix it using your methods. :)

Ah, that's why it got flagged :) Thanks for informing me.

I'll report back after testing.

Katie Riggio

Hi there, Nicole. Really sorry you're also hitting a snag with your course.

While I don't have a solution to share from Stian's case at this time, I'd love to take a look at your setup and see if I can reproduce the behavior. You can either add your .story file as a comment by using the Add Attachment button in your reply or send it privately via this link. Additionally, could you let me know if you published the course for Web, LMS, or something else?

Looking forward to helping!

Katie Riggio

Hi, Stian. I see it's been a while, so really appreciate you taking the time to circle back on this! 👋

Ah, sorry to hear that changing the When revisiting: slide property to Resume saved state didn't help. Out of curiosity, have you had a chance to test the troublesome Storyline 2 course in SCORM Cloud to see how it behaves in another LMS environment? 

Thanks again, and we'll be standing by if you need anything else!

Katie Riggio

Thanks for testing your course in SCORM Cloud, Nicole!

Out of curiosity, do you have a question on the last slide of a scene? After some digging, I see a logged issue in Storyline 2 where our team is looking into the following behavior: learners get stuck in Review mode if there's a question on the last slide in a scene. Let me know if that matches your setup!

If it's different, this is truly a perfect opportunity for us to take a closer look at the .story file. Would you be willing to share it here or privately through this link? Fingers crossed, as we'd love to help you solve this oddity. 🤞

Nicole Sarmiento

Hi Katie! The last slide in this scene isn't a question but the problem occurs whenever question slides are reviewed. The Next button shows up for a few of the question slides but at one point, a Submit button will be available instead, even if the user had already answered the question. Clicking the Submit button then does nothing.