Courses don't show as complete based on Quiz result

Jul 24, 2020


I'm hoping someone can help.  I'm stumbling around on the dark.

I've have a course with a quiz (in articulate 360), 5 questions, if you get 100% you see the Success layer. When this layers timeline starts the course "completed/passed" gets sent using a trigger.  If you get less than 100% you see the Failure layer (unfortunate rushed naming) which sends "incomplete/failure".

When I assign the course and do it I can get it to be in progress when I fail - which is OK given that I've set the reporting to Passed/Incomplete (based on what's been working when using RISE).  But when I re-attempt the course, which is allowed, the result doesn't change if I pass.

Clearly I'm missing something.

I've included screenshots of the layer triggers I've been adjusting to fix this but there's probably something I'm not doing or considering.

I'd appreciate any suggestions that might fix this.

FYI: I have tested this in our LMS (PeopleStreme) and on CloudSCORM.



6 Replies
Marc Koenecke

Thanks. I'll update the post soon. In the interim, I've managed to get the course to push through an in progress "status" when the course has been attempted and the learner hasn't passed the quiz, and when they relaunch and pass it now shows as complete - I gave up on the pass/fail because it didn't look like I was seeing the result when they failed and all we really need here is a complete/incomplete.

Marc Koenecke

I've gotten this working.
I'm still not happy about the fact that after the "fail", the result is shown as "in progress" - I'd hoped to see what answers they'd selected (or at least the score they got), but as I mentioned the quiz score isn't important for this course (I'm thinking ahead to when it will be) - and this may be an LMS issue anyway.

So, I can fail, the course is marked as in progress and I can return and pass.

But, there's a glitch.  For some reason retrying the course while still in the session doesn't reset the score - you still fail, even if you get everything right.  I think it's an issue relating to each question slide not resetting on being viewed again - there may be a question that is holding on to its initial value.  I'll dive back in and see what's happening.

Marc Koenecke

I discovered that one of the slides in my course, a drag and drop interaction I've used as a learning exercise is linked to the quiz I'd created as a knowledge test.

This explains why the result wasn't a rounded value i.e. 10%, 20%, 80% rather it was a 83% etc.

Quiz problem solved now to republish and pull the course back :( 

This discussion is closed. You can start a new discussion or contact Articulate Support.