Courses Not Registering Completed

Here's the skinny. I'm publishing AICC formatted learning modules with built in quizzes, loaded on a networked server, and launching through SuccessFactors Plateau LMS using Internet Explorer 8. LMS users call in with reports that their learning is not recorded when they complete the module and quiz. I am able to complete these modules proxying through using a group of test users. I can also complete learnings on my own user profile.

I cannot replicate the completion error on the live server, and have ruled out my publish settings. Is there anything else I should consider?

38 Replies
Steve McAneney

Hi Joshua.

I had similar problems with my LMS for almost a year, before I discovered users were ending the e-learning incorrectly and the scores from the quiz weren't being uploaded to the LMS. (In this case the e-learning opened in a pop-up window, but users were closing both the e-learning pop-up and the base window before scores could be transmitted)

Once I redesigned the e-learning so there was only one, correct way to end it all of my problems went away.

Hope this provides some inspiration.

Ashley Terwilliger

Hi Joshua and welcome to Heroes! 

Since you're not able to replicate it yourself, you'll want to find out from your users any other specifics about how they're accessing the course and closing the module. As Steve shared, they may be closing it in a way that prevents the score from updating or you may find it's particular to a certain browser. You could also have them use a site like Screenr to record the behavior for you to try and replicate the steps on your end. 

Joshua Spicer

Thanks for the responses. I've tried several more things at this point. My LMS forces a popup window to load, regardless if I choose to publish with that option checked or not, so that solution is a no go unfortunately. My userbase also largely doesn't have the capacity to provide feedback that is helpful (most of them can't even tell me what operating system or browser they are on... older workforce, new tech kind of deal. Can be painful at times).

So anyway, I've removed the submit button from the slide navigation controls and have added a 'Submit Results' button on the Success Layer of a result slide. Since the Submit navigation control was attached to the base slide, it would appear regardless if the quiz was passed or not. My new button only appears if the quiz is passed. It has a trigger set to 'Exit Course when User clicks'.

I'm still finding that quiz recordings are not successful however.

Is there any reason to use the 'Submit Results' trigger if I have quiz tracking enabled in the publish settings?

Ashley Terwilliger

Hi Joshua,

Have you removed the "submit button" from all slide navigation as if the user was going to submit all their answers at once like described here.? Even if you have the quiz tracking set up to track that results slide you'll want the submit results button as well. Since you've placed this exit/submit button on the success layer - do you not want the user to have a score recorded if they don't pass? 

Steve McAneney

I ended up adding an "END COURSE" button to the quiz results slide. This button triggered a pop up (layer) which told the learners the CORRECT way to close the course. Within the pop up window was another button which triggered a course exit. 

You still don't know what's causing the problem though. Might have to stand over one or two users who had problems and watch what they are doing.

Joshua Spicer

Hi Ashley,

Correct. I have my results slide set up to only show the submit learning button if the user passes the quiz. If they do not pass they are prompted to retry without submitting the results. My company requires all users to pass, and they are given as many retries as they need, so because of this I set the results slides up to only record results on a pass condition. Should I consider another way of doing this?

I have followed the tutorial you provided to see if submitting all answers at once will make a difference as far as completed quizzes recording when they are submitted.

Steve,

I use something similar, and I've love to be able to stand witha user to view their screen, but we have a lot of off site campuses so I can't make it to everyone. I am trying to set up remote desktop access with our IT guys though, so I can watch their screens from my desk.

Thank you both. I will follow up if there is any success.

Ashley Terwilliger

Thanks Joshua for sharing the additional information here. If you're able to determine anything else that is happening in the file please keep us posted. Have you checked in with your SuccessFactors team to see if they have any suggestions on what may be happening within the LMS when users are closing the course?  There is also a general article here on troubleshooting common LMS issues that may help you. 

Joshua Spicer

Thanks for the link Ashley. I didn't think to mention cross domain setup, which that article touched on (and gave a few solutions to). That may very well be the problem, so I will test that solution. My attempts in adding submit learning triggers and whole quiz submission as opposed to question by question yesterday only resulted in partial success. 

Eric Nalian

Hey Joshua,

We are currently experiencing the exact same issue with SuccessFactors!  It is awful.

Here is what we have done so far to try and solve the issue:

  • Submitted helpdesk requests to their support team on a regular basis (since last August!).
  • We were told that SCORM will work less than ACICC does on SuccessFactors.
  • There is a user group on Yahoo where many companies are experiencing the same issue.
  • Ruled out that it is Articulate Storyline/Presenter that is having issues - We have courses from 3rd party vendors that we have the same issues with
  • Recorded about 40 Fiddler sessions to capture the data that is being sent to the LMS.  We had 5 team members in a conference room trying to replicate the issue.  We were able to replicate it many times, however there is no pattern.  All we have been able to find out so far is that if too many people (we tested it with 5 people) take a course at the exact same time, the LMS will not record any data.
  • They are trying to push us to purchase iContent so that our courses will be hosted on their survey instead of ours (because the server set up could be an issue).  There are several users in the Yahoo group that are experiencing the same issue there as well.

We are also experiencing an issue where the LMS randomly logs users out mid course (a separate issue for another day).

To resolve this issue - we are working with AASONN to find a solution.

I'll keep this thread updated as we find out more information on resolving this issue.

Glad we are not alone in this.

-Eric

Joshua Spicer

Eric,

I'm so glad it's not just me! Hah. SuccessFactors support is awful. The older Plateau gets, the less support they offer for it. We're planning on transitioning to their cloud later this year, but even their sales reps are a pain to deal with. I may suggest to my manager to look for a different LMS/PMS all together. I was hoping they'd improve under SAP, but alas, they have not.

I think I have also ruled out that Articulate is the problem. My material works flawlessly on the SCORM cloud, and I use AICC exclusively.

I am checking my cross domain stuff right now (I think that is the culprit), but it's interesting that you mention too many people taking the learning at the same time causes recording failure. We have anywhere between 100 and 1000 people trying to do this on a daily basis in addtion to daily automatic report generation. Thats a lot of load, so it would make sense if communications aren't getting through.

Pat Bowie

I'm experiencing an issue with a Quizmaker quiz that resides on my LMS, (which is Sum Total Systems - great support from the LMS by the way), is showing an inactive "Finish" button at the end of the quiz.  Employees have had to use the X to close the quiz (to get out of it). Their final score is not recorded if the employee is not able to click on the "Finish" button at the end of the quiz.

I thought I had identified the common denominator for this issue...thinking that we need to run our LMS using Google Chrome, instead of internet explorer. However, that didn't fix the problem. I've had so far about 60 employees to take the same quiz...with 6 experiencing this problem. We made all things equal as far as the web browser used for the LMS, (Google Chrome). I had one employee who had an active "Finish" button, while the other employee's "Finish" button (in the same Quiz, on a computer that displayed the button before) did not.

Has anyone experienced this issue before in a quiz using Quizmaker? This is my first encounter with this happening.

Leslie McKerchie

Hi Pat! Looks like you have a question about Quizmaker.

Is your quiz located within a Presenter Presentation? I have seen this reported in Quizmaker '09 when the quiz is the last slide in the presentation. You can read more about that in this article.

Aside from that we may need to look at your files and you can submit that here, which will also get us out of the Storyline forum

Ashley Terwilliger

Hi Kara,

Thanks for including the screen shots, and everything looks right there. Have you tried clearing your browsers cache after updating to ensure it's referring to the latest update you have? Also, you may want to test your course at SCORM Cloud to see if it behaves normally there. You'll want to follow these directions to test the AICC content. 

Kara Jones

Hi Ashley!

I cleared my cache and, unfortunately, that did not help.

I followed your suggestion (and helpful links!) to test the course in the SCORM Cloud. Here’s where I get confused. It seems like the adjustment I have to make so an AICC course will test in the SCORM Cloud overrides the change made to the .au file because when I open the .au file in Notepad where I would put the path to the asp file there is the “index_lms.html” text which is allowing it to work in the Cloud.

Regardless, I first made the changes necessary for it to play in the SCORM Cloud and didn’t make the changes to the .au file. It plays.

I then made the changes to it so it would play in the SCORM Cloud and also made the changes to the au file. It does not play. So, I don’t know that I truly tested the course in the Cloud.