Cut/Paste Of Copied Text STILL Doesn't Retain Source Formatting?

Greetings,

In SL2 (current as of today) when I cut/copy and paste text I can't get SL to retain the Font style nor size of the source text?

I've searched the forum, learned about setting the font style in slide master view ... done that.

I also understand that if an object is selected the pasted font will be inserted using the theme font ... yep, works like that.

However (and per SL knowledge base), if I do NOT select an object first and paste text, the text is supposed to be inserted into new text box AND retain font style and size of  source ... nope, not for me?

For example:

SL default text box set to Arial 12pt, in slide master the font set to Arial (across all layouts).

From Word doc I copy Times New Roman 10pt text.

If I DO select an existing text box (Arial 12pt) and paste = Arial 12 pt ... ok.

If I DO select an existing object (button for example) and paste = Arial 14 pt ... sort of ok, why 14 vs 12 pt?

If I do NOT select an existing object and paste = Arial 12 pt, not TNR 10pt???

Thanks for the help, it's driving me crazy this morning!

 

 

3 Replies
Ashley Terwilliger

Hi Ken,

When you paste the text in are you using the "right click" then paste - or just the hot keys? It looks like when I right click and choose to keep source formatting, I'm able to paste it in as it was within the Word document (TNR 12) and if I just use the hot key of CTRL + V then, it defaults to my theme font. It looks like our team is aware of some inconsistencies with CTRL+V, so in the meantime I would suggest using the right click option. 

There is some additional documentation here about pasting text into buttons and that it may not work as expected. I know there was this knowledgebase article for SL1, but with SL2 a number of improvements and changes were incorporated into the text editor - so I don't see documentation that the same rules apply. 

Ken Resner

Thanks for the prompt response Ashley. I continue to be impressed (and appreciative) of SL staff responsiveness on this forum.

Hmm ... interesting. I've been a "CTRL X-C-V" kinda guy for eons (eons, like since DOS) ... so, no wasn't using right click method.

Just tried right-click and "keep source formatting" ... a-n-d ... works great ... THANK YOU. 

Regards - Ken