Disable Hotspot?

Good morning!

I am creating a lottery ticket type of game to include in one of my projects. I currently have three areas that must be scratched off. I adapted an example Tom posted on another post that uses hotspots. Once the user moves the quarter across the hotspot 4 times it shows the image underneath. What I would like to do is limit the activity by only allowing the user to select one scratch area. If they do not select the correct scratch area it wont allow the user to scratch either of the other two areas. Any thoughts?

Here is a link to my example: woolwinewebdesign.com/scratch

12 Replies
Mark Woolwine

Thanks for all of the comments. I discovered Dave's post the other day and adapted it. Phil I thought of the transparent shape after I posted this. The only issue I had was that I could only get the state of the transparent shape to change when I let go of the scratching coin. I could easily keep a hold of the coin and scratch the other two scratch areas. Thoughts?

Shon Isenhour

I know it's been a while, but I stumbled across this post and figured I would add some insight in case people were still looking for a solution to disabling a hotspot.  First, you CAN technically disable a hotspot. 

Set up a variable for each of the hotspots you want to disable.  You can do numbers or true/false.  For this example, I'll do T/F.

Create your T/F variable and set it to default to false. 

Next, start at the destination of the hotspot.  Make a trigger that changes the T/F variable to true when the timeline of the new slide starts.

Now go back to your hotspot and create a trigger to go to 'destination' when you click it.  Create a condition in this trigger. In this condition tell the trigger to only go to the destination of the variable (you created earlier) is false.  

Now, you can click on the hotspot, it can take you to your destination (or whatever action you want) and then it will be disabled afterwards.  The same principle can be applied to almost anything you are trying to create where you need to disable the hotspot.

Super simple.  Hope that helps someone.