Drag and Drop item not returning to initial state

I am trying to create a drag and drop activity similar to one David Anderson (thanks David) demonstrates here: https://youtu.be/SYJ-duE-r5g?t=407

I'd like to provide the kind of immediate feedback he illustrates where the drop item changes states for correct and incorrect but I am unable to make the drop items return to the initial state once they have been triggered as incorrect.  In my case, once an item has been dragged onto the incorrect drop zone, it remains the "incorrect" colour even when dragged off of the incorrect zone.  I can't seem to find where to correct this. Can any one point me to resources that might explain how?

Thanks

5 Replies
David Anderson

Hey Meg - 

You'll need a way to reset the drag items when they're dropped (or dragged over) the area outside of the drop targets.

I recommend using a hotspot to reset the drag items. See the attached file and let me know if you have any questions. I'd be happy to put a video together for you.

Meg Goodine

Aahh. That makes sense. Thank you so much for the speedy response. I noticed in your sample file, if you click and drag the item after making an initial choice, the item reverts to normal when you click and drag it (as long as you are still clicked on it ) even though it is below the hot spot--is that just default behaviour or is that something that needs to be set.

Thanks again for your help.

David Anderson

Hi Meg - I noticed one thing I forgot to change in the file I sent. I would uncheck the option to delay feedback so the Drop Correct and Drop Incorrect states show when dropped on the targets.

The hotspot should be on the bottom layer of the timeline. That means you could drag the hotspot to cover the entire slide and the interaction would still work as long as the drop targets are above the hotspot. If you move the drop targets below the hotspot, then they wouldn't work since they would be blocked by the hotspot.

I think that's what you're asking:-) If not, please let me know!