Enter Key to Advance Slide (SL360)

On the image below you can see I have a Continue button. I'd like a user to be able to advance the slide by hitting Enter key (which they do now only by hitting the Continue button). 

I'm using the code:

Jump to next slide
When user presses the Enter key

I've tried this as a slide trigger and as a trigger associated with the Continue button. 

Any hints as to what I'm doing wrong here?

Thanks!

27 Replies
Crystal Horn

Hi there, Ras.  We found an issue where the trigger based on the user pressing the Enter key is not working unless they press the Tab key first.

I'm sorry that this behavior has got in the way, for you!  Normally, you would assign that trigger to the slide, like you've already tried.  Currently, the workaround is advise the user to Tab on the slide before hitting the Enter key to advance.

I'm tagging this discussion so I can update you on any changes or fixes for this behavior.  

Crystal Horn

Hi everyone!  We just released another update for Articulate 360, and included a few important fixes and new features that you'll see in the release notes here.

We fixed some triggers that didn't always work correctly in HTML5 output, including triggers that execute when clicking outside an object, key-press triggers, and conditions that compare two numbers.

Just launch the Articulate 360 desktop app on your computer and click the Update button for each application.

Let me know if you have any questions, or feel free to reach out to our support team!

Katie (Gokhshteyn) Riggio

Welcome to the community, Kate – I'd be happy to dig into this for you!

We released update 3 for Storyline 3 – all of the features and fixes can be viewed here! One of the fixes in that update addressed an issue where the trigger "when user presses a key" was not functioning unless the Tab key was pressed first.

To dive in:

  • Are you able to share your .story file here, so that we can take a look at your file? 
  • Can I confirm what version of Storyline 3 you're using?
  • Are you publishing your course to Web, LMS, or something else?
Michael Jones

Hi everyone,

I realize this is an older thread, but have there been any reports of this issue still existing—at least on user-created slide layers?

We're dealing with this issue where a "Jump to next slide when user presses Enter" trigger doesn't work on feedback slide layers. As a workaround, we moved the trigger to the base-layer and added a variable that toggles to ensure the action gets focus. This works for the default correct/incorrect/try again feedback layers, but not on a custom added layer.

It appears that the user-generated layer causes the content area to lose focus, and therefore does not fire the trigger properly.

We have another workaround up our sleeve to consolidate the custom layers into one of the default feedback layers, but wanted to get confirmation as to whether or not this is still an issue. Could it possibly be an issue that has reemerged with a recent update?

We haven't installed the latest release from June 22, yet.

Alyssa Gomez

Thanks for reaching out, Mike!

I haven't heard any rumblings around the forums of issues with keypress triggers on feedback layers. I created a quick sample file to test this out, and it appears to be working correctly in Storyline 360 Update 17 (Build 3.17.16188.0). 

Could you test this sample file and let me know if pressing the Enter key allows you to advance to the next slide?

I'll be standing by!

Justine PIDOLLE

Hi all !

I would also like to use trigger "when the user presses the Enter key" to hide Try again Feedback, but it does not work either. I try with several keys, but only TAB key works ... 

Is there always an issue with this kind of trigger ?

I use Storyline 3, (update 4 - 3.4.15731.0)

Thanks for your help !

Alyssa Gomez

Hey Justine!

I'm finding some strange behavior in my own testing, and it seems to closely match what you're seeing.

  • On Hotspot slides, when I press Enter on the Try Again layer, I am automatically advanced to the next slide.
  • On Text Entry slides, when I press Enter on the Try Again layer, nothing happens. I have to click the slide area before pressing enter to hide the layer. 

Let me get this in front of my team so that we can verify this is a bug. Sometimes my team catches errors in my logic and we don’t have a bug after all. Of course if that’s the case, I’ll let you know!

Thanks so much for bringing this up to us, and I'm sorry it's slowing you down!

SDI Project

Yes, I'm having trouble with the pressing "enter" to advance to the next slide when using a text box too. I have to click outside of the text box before it will work. Pressing the tab key before pressing the enter key does work, but I don't want to do that for my project as it doesn't mimic what you'd have to do in real life. 

If there is a workaround for this, please let me know. 

Thanks!

Crystal Horn

Hi there, SDI Project. Tell me which version of Storyline you're using (Help > About Storyline), and let me know about the slide setup.

  • Do you have a text entry field?
  • Is it a slide that's part of a step-by-step screen recording you've inserted?
  • Do you have any feedback layers?
  • If you can share a screenshot of your triggers as well, that would be helpful.

Thanks!

SDI Project

Hi Crystal, 

I've attached the slide/timeline, triggers, and layers (one of which could be deleted.. I just added it in for fun while learning the software). 

Yes, it is a text entry field that I'm having problems with. I don't want Enter to create a new line. I want to limit it to one line for the name. I want Enter to go to the next slide instead. 

There isn't a screen recording. 

We're using 360.

If you have any insight, that'd be appreciated. 

Thanks, 

Sherry

 

Leslie McKerchie

Hi Sherry,

Thank you for sharing those details.

One thing that was not clear in your images is where the focus of your trigger is. Is it on the slide or on the text entry object?

Take a look at my attached example where the Enter key is working to proceed to the next slide.

With your permission, I'd like to take a look at your project file to investigate what's happening. You can share it publicly here, or send it to me privately by uploading it here. I'll delete it when I'm done troubleshooting.

Rory Lavender

I am now having the same problem with the Enter key not working consistently on text entries, which is 99% of what we develop. My story seemed to work up until yesterday afternoon, then the Enter key just stopped responding. Today, it started off fine, then stopped working again. All of this in Preview mode, BTW. I remembered that I updated the software (A360) at some point yesterday, so I fell back to the previous version, but that didn't help. I kept trying to find a pattern to the problem, but the results are inconsistent. I have uploaded my story using the above link, plus a document outlining my test results. Thanks.