Error "Unable to acquire LMS API"

Hello everybody,

When publishing the SL360 projects I  get an error "Unable to acquire LMS API, content may not play properly and  results may not be recorded properly". I try to launch the project by clicking "View project" button after publishing and always get such error. I am going to upload the scorm in our corporate LMS portal and I think that i will have problems with recording results in the published course. Now I am testing my project  in SCORM cloud and the results of the tests are not recorded at all.

Here is the link to the problem scorm: https://cloud.scorm.com/sc/InvitationConfirmEmail?publicInvitationId=e97665c7-fb67-4bb7-9dd7-44300e17079c

I have deleted all unnecessary slides from the course. The project consists of 3 little quizzes and the final score result is a combination of the points from these 3 quizzes (the very first slide). But the score is not recorded unfortunately.

I have attached the error window , log and SL360 file.

I must launch very important courses and test asap but always get such errors. I'm trying to solve this problem several days and nothing happens unfortunately. Hope for your help.

9 Replies
Leslie McKerchie

Hello Mikhail!

Are you experiencing this error when viewing the published course at the link provided? Can you tell me the steps to replicate as it did open for me and I didn't get an error.

I fear that you may be viewing the project locally since you mention clicking 'View Project'. You want to be sure that you are zipping the contents from the Publish Successful dialog box and uploading to your LMS for testing.

When you view a Storyline 360 course on your local hard drive, you'll encounter security restrictions from the computer, web browser, Flash Player, and network that can cause various features of the course to fail. To test your published content and share it with others, it's best to upload it to a web server or LMS. See this article for details.

Mikhail Mumlev

Hello Leslie,

I am able to open the scorm without problems on my computer and in LMS too. The course works fine. This is not a problem.
But the problem is that the score of the published course is not recorded in LMS at all. I get such error in any LMS system. I tested, e.g., the scorm in the SCORM cloud and in my LMS and always got the error – the scores were not recorded.

But finally I have found the reason of such strange behavior of the published scorm courses!

If you tick the «Launch player in new window” before publishing the course you always get the error as I described in my letter. But if you DO NOT tick that field everything will be published without any errors at all and the score will be recorded without any problems.

Launch player in new window

I spent about a week to understand what was going on and to find the bug in SL360. I think this is rather critical error. I strongly advise you to check the system and solve that problem.

If you have any questions, please, ask.

Best regards,

Mikhail Mumlev

Ashley Terwilliger-Pollard

Hi AR,

If you receive an "Unable to acquire LMS API" error when launching Articulate content in your LMS, this may be caused by the version of Java that you have installed.

Some LMS’s use a Java API object to load content.  Since content created in Articulate does not require Java, please do the following:

*  Contact your LMS provider and ensure that your installed version of Java is compatible with the version of the LMS you are using.
*  Ensure that you have published your content properly as described in the following article:
http://www.articulate.com/blog/publish-to-lms-with-studio-09/

If this issue persists, look at setting your course content to open in a new window (you'll find this within the player settings).

Leslie McKerchie

Hi Mary,

Thanks for reaching out and I'm glad that you were able to find a workable solution. I'd like to understand the issue that you were previously running into.

The issue you are seeing is with your score reporting vs. the course launching? 

Are you able to replicate this behavior in SCORM Cloud as well or is the issue only happening within your LMS?

If you need us to take a look then, with your permission, please share your project file with our support engineers to investigate what's happening. You can share it privately by uploading it here. It will be deleted when troubleshooting is complete.