Feedback master slide

I have written hundreds of questions in Articulate Storyline.Some of the answers to the questions are very short, some are quite long. When I publish them, if the answer is very long, in the 'incorrect answer' box, the writing is so small I can't read it.

Is there a way to re-size the 'incorrect answer' slide so that it automatically changes size to accomodate the amount of text that is there?  Also, I would rather not have to go into each slide to change the setting, is there a global setting for each incorrect master slide that I can use so that it automatically does it.

Thank you very much!

11 Replies
Rebecca Fleisch Cordeiro

Hi Helen,

It's easy enough to adjust the text box in the feedback master, BUT you also have to consider the position of the continue button and also the size of the rectangle that the feedback answer box sits in.

To adjust the feedback answer box

Click the View tab and then Feedback Master

Right-click the "Click to edit feedback text styles" object (Placeholder 2 on the timeline) on the very top slide and choose Format shape from the shortcut menu

Click Text Box on the left and, under Autofit, click "Do not autofit"

This is also where you would adjust the size of the rectangle that the feedback box sits in (Rectangle 1 on the timeline). You'll need to have an idea how wide/tall this will need to be. Of course you can go back and edit it later.

Close the Feedback Master

Now on your correct and incorrect layers for your quiz slides,  you'll need to move your continue button and you can type as much (within reason!) as you want in the text box.

Please shout out with any questions.

Daniel Brigham

Hi, Helen:

Rebecca gives good advice above. If you have a wide variety of text length responses, I'd go into Feedback Master and insert a second slide master and call it something like, "long responses." When you are building or editing a question, SL will give you the opportunity to choose either of your slide masters. Another option. --Daniel

Helen Elder

Hi, 

Thank you guys for your response!

I've selected the option to 'resize shape to fix text'. The problem with that is that the text then goes outside the box - as you pointed out I have to also change the size of the actual box and the placement of the 'continue' button.

So I just want to make sure I have understood this correctly. There is no 'quick fix' for this?? - I have to go into each slide where there is a lot of text and select 'resize shape to fit text' and then also change the size of the box itself (and the placement of the continue button)??

I'm double-checking this because I have hundreds  of slides that this applies to and it's a mammoth task to go back into each one individually - so it there was any quicker way that would be great! (They were all imported from Quizmaker so it's not a case of writing new ones and setting up the master slide).

However, from what you've said so far I don't think there is :(. I can live in hope haha!

Many thanks!

Helen

Rebecca Fleisch Cordeiro

Hi All,

Daniel, your suggestion regarding making a second slide master (or more if necessary) is an excellent one...at least most of the time.

Helen, regarding the size of the box, that can only be done on the "top" master. But you're only doing it once, right? Same as with the C/I Feedback text boxes. You're only doing the "do not autofit" at the master level

So the only thing you have to re-position is the continue button. Sadly, I believe you WILL have to do these for each quiz.

Also, though, if you DO decide to use a separate feedback master, you'll have to go into the C/I layers for each of the quizzes, right-click on the slide, and apply the custom feedback master. So for you it might be easier to just have the one master.

I've attached a story where I've inserted a new custom feedback master. Do this by

Right-clicking on the original feedback master and choosing Duplicate from the shortcut menu.

Right-click again on the original and choose preserve.

Click on the top of the custom feedback master and resize the box, set the feedback text box to do not autofit.

Then I did as I described on each quiz C/I layer and applied the new custom master.

I've put "lorem" text on the C/I layers, just to show that it works.

Please shout out with questions!

Helen Elder

Thanks guys,

OK I've been experimenting with all the techniques. The problem I have now is that by changing the size of the'rectangle' on the 'master feedback slide' it means that for all those incorrect slides with short answers (and the 'correct' slides which only have 7 words) they now look a bit silly in such a huge box.

For example. I have a quiz with 3 slides. The answers on the first 'incorrect' slide will be 3 words long, the answers on the second will be 50 words long, the answers on the third will be 10 words long. There is no uniformity in the answers (and there are hundreds of quizzes). So actually, only the box for slide '2' needs changing, but just to confirm -  I need to do it for the whole 'quiz' right? If this is case that's fine, as it's still better than having illegible text!

On a separate note, can you help me with another issue?  For questions where the user has to type in the answer, sometimes there are a variety of answers and each answer appears with green lines around it, which we don't want. How do I remove the green lines? I've attached a screen grab.

Thank you! I can't tell you how grateful I am for your help guys!!!

Rebecca Fleisch Cordeiro

Helen,

If you only need the box to be bigger for a few slides, here's what I'd do:

First, I'd still change the feedback text box on the top master slide to "do not autofit" so you don't need to do it for individual slides when you have a lot of text...at least for the future.

For existing slides, you may need to go in and apply that master to the C/I layers for those slides with long answers (to apply the change), in which case it might be just as easy to simply go into the C/I layers and change the text boxes there to do not autofit.

And, again , if you only need the rectangle to be larger for a few slides, I'd

  • create a new rectangle shape on the C/I layers for those few slides
  • Be sure to drag it down to the bottom of the timeline so your answer will show through
  • Move the continue button down

And, if you want the new rectangle to have the exact same formatting as the "default" one, I'd copy that rectangle from the top of the feedback master, paste it offstage on the C/I layer, and use the format painter to copy the formatting from it to the new shape.

If any of that is unclear, please shout out.

Jim Schoemer

Most of the questions/suggestions in this post seem to apply to the length of text and the size of the box. My problem is that I resized the box just fine, but I wanted to enlarge the size of the feedback text for readability. I did this on all the relevant masters, but when I went to preview the feedback page, the box was larger but the type was not. Any ideas on how to retain type size changes made on the master?