Flash Player 23 and Later in Google Chrome - Local Playback of Published Content

Hi all, 

Our team recently discovered an issue with Google Chrome and Flash player 23 (and later) that is causing some issues with the local playback of published Storyline and Studio content. This is a new security feature of Flash player 23, and if you attempt to launch content locally you may see just a spinning circle or Flash player notification.

Our recommendation at Articulate is to always test the content in the intended publish environment by uploading to your web server, LMS, Articulate Online, etc. You can see a few options detailed here for locations to test your content. 

If you need to view e-learning projects on your local computer, your best option is to publish for CD, then double-click the launch file in your published output.

Another option for local playback is to add one or more trusted locations to your local Flash Player settings. For example, you could add folders where you commonly publish content, such as your desktop or the My Articulate Projects folder in your documents.

Please feel free to let us know if you have any questions about this! 

146 Replies
Sarah  Newsom

I have a question about this.  We upload to an LMS, but recently have been getting "Couldn't Load Plugin" errors.  I had the users send me a screen shot because I cannot duplicate the issue on my PC or in my lab, both of which are using Chrome.  I have had over 3500 people log on and take the courses with no issue and now have 3 people who are getting this error.  They are getting it in our store computer and at home.  Taleo says they don't require plugins and that it is my authoring software.  But, how could it work for some users and not others? And is this the same issue as what you are describing?

Ashley Terwilliger

Hi Sarah,

So the user isn't accessing it through Chrome- but you are and it plays fine there? Then I don't think this is the same thing - andI don't believe the Chrome update with the Flash player mentioned is fully released yet either. 

Also, this would just be for viewing local content - and if you've already uploaded it into your LMS that should be fine. 

When they got the plugin error message do you know which plugin it's referencing? What browser and version are they using? Are you using Storyline 1 or 2? What update was it published with? 

Sarah  Newsom

All users are accessing it through Chrome in our stores, that is our set browser.  I also access through Chrome - without issue.  We launched our classes in March 2015, haven't made any changes, and haven't had this issue before.  I had a store call last week with the issue, sent me the screen shot, then the next day it worked.  We didn't do anything to it.  But a store called me on Thurs. and is still getting the same error. My IT department is at a loss and I reached out to my LMS support who said it was storyline.  I have SL2 and publish with that.  I don't know which plugin, I am unable to access their computers, but my IT department said they didn't have any outstanding updates.  I also don't really know how to check which update I published with.  How do I find that out?  I published it 3/17/2016.  I am checking with my helpdesk to see what version of chrome we are on.

 

 

Ashley Terwilliger

Hi Sarah,

The image you shared above didn't look like Chrome, so that threw me off a bit. 

I would suspect March 2016 if you were on the latest update it would have been Update 7 . You can see the release notes here with different fixes, but nothing specific to that version of Chrome. My chrome is on Update 52 right now.  We're also now on Update 10 of Storyline 2. 

So, if you haven't changed anything in Storyline and you're on that version of Chrome, I can't think of a reason why the plugin message would be display. Does that LMS support the latest version of Chrome? Do you know if your IT team disabled Flash as a default in Chrome - you could check by going to a site such as supportdetails.com and that'll tell you if flash is enabled

 

Ashley Terwilliger

Hi Sarah,

You'll also want to make sure if you disable the Flash plugin, that you publish with HTML5 each and every time. You'll want to note that the Flash plugin is for the entire browser, so there may be other elements that users access in that browser that could cause them difficulty (outside of your LMS and Storyline). 

Pierre,

You can still view SWF content in all the major browser, although some like Chrome are starting to disable it by default. It's easy enough to turn Flash back on using the "plugins" setting within any browser. The issue here is that Chrome is no longer allowing the local playback element of the Flash content due to a new security feature introduced in Flash Player 23 that disables local playback of Flash content by default. So it's a bit different than the published content being viewed in the intended environment as well. 

max maizels

there is alot of computer speech above with which i am not familiar

i do know that my trusted storyline files which have been working fine, now after an edit to the storyline file, and attempt to publish, publish works fine, but when i click view project, all i get is the turning circle, the files are all in the directory

i copied the file to my 2nd puter and pub w storyline, but got the same undesired results

 

i guess this is the payback i get for working with computers

 

would you please suggest my next steps

max

Russell Still

Wait... You're saying the only way to test published output is to go through the potentially long FTP procedure and upload it to the web server???

Please tell me this isn't a "permanent" solution to this problem. I just discovered this today and cannot preview any of my newly published materials. If I have to upload everything to the server this will be a HUGE decrease in my productivity. I see this as a show stopper. Can you tell me what is being done to correct this?

 

 

Robert Jordaan

Hi guys,

I'm sorry but this workaround is unacceptable, I cannot publish modules to our live servers before the QA department has not signed off on the content, in effect this has halted all my team's development, I'm talking about content for 1500 users in 23 countries here.

Please find a way to fix this or give me an offline workaround that works. The Flash Player trusted locations doesn't fix the issue either.

max maizels

Dear all

i simply opened the files published to my local computer with internet explorer and worked fine.

if flash player has some updated security feature, i am not understanding why a suggested workaround is to disable this.....wont this remove the added security.

so seems like i am fine if i open in IE, but as there are always going to be problems (welcome to working w puters) would it be reasonable to ask storyline smart folks to simply make a screen cast of what to do...

that would have helped my insecure compter fingertips alot

so i will wait to hear from SL re a fix w use of chrome, bu will grudgingly use IE in the meantime

thanks to all for a "quick" fix

max

Pierre Jouan

Hi all,

The solution in the first link in Ashley's post works.

- if you publish to your local drive, add your folder or your drive to the list of trusted location as shown in the article

- if you publish to a network share, map this share to a drive letter and use it when you define your publish location in SL