Flash Player 23 and Later in Google Chrome - Local Playback of Published Content

Hi all, 

Our team recently discovered an issue with Google Chrome and Flash player 23 (and later) that is causing some issues with the local playback of published Storyline and Studio content. This is a new security feature of Flash player 23, and if you attempt to launch content locally you may see just a spinning circle or Flash player notification.

Our recommendation at Articulate is to always test the content in the intended publish environment by uploading to your web server, LMS, Articulate Online, etc. You can see a few options detailed here for locations to test your content. 

If you need to view e-learning projects on your local computer, your best option is to publish for CD, then double-click the launch file in your published output.

Another option for local playback is to add one or more trusted locations to your local Flash Player settings. For example, you could add folders where you commonly publish content, such as your desktop or the My Articulate Projects folder in your documents.

Please feel free to let us know if you have any questions about this! 

146 Replies
Sue DiMaggio

I, too, am no longer able to see or preview any created courses.  This just started today.  I can't see any published content, either on the network drive where they usually reside, or locally.  I even published as CD, unzipped the folder locally, and tried to view the file that way.  Nothing seems to work.  Any other suggestions?  

Ashley Terwilliger

Hi Sue, 

This sounds a bit different than the issue described here at the start of the discussion Are you typically creating your content on a local drive and publishing locally as well per the recommendations here? You mentioned normally residing on the network drive - is that post publish that you move them there? How do you normally publish if not for CD? Did anything else change on your set up or environment? When publishing for CD you will need to have IE installed as our player for CD is based on a set up of Internet Explorer. 

Let us know if you can provide any additional information on changes within your environment or where the files were previously playing correctly as that may help us troubleshoot further! 

Ashley Terwilliger

Hi Russ,

Sorry for the delay here - Mondays... :) 

Anyway, the link that Pierre shared is the actual place to make those changes, within that Flash page - not within a Chrome setting. The directions I shared were in regards to the trusted locations, and you'll see Logan's comment about adding the path in directly vs. trying to navigate to a folder.

Let us know if you need anything else. 

Sue DiMaggio

Hi, Ashley,

Unfortunately, because of company security rules, we are required to create and publish content on the network drive. That being said, when we’ve had the occasional issue with publishing on the network, we’ve published locally and then copied to the network. In addition, the courses I’m referring to are not new courses – in other words, they’ve been on the network for months, and I’ve never had a problem trying to view them.

We publish to web, rather than CD, although we have one customer who reviews files for whom we have to publish to CD.

My guess is that something has changed in our environment, since a company-wide monthly update was performed this weekend. I’ll see if I can get any info from our IT group.

Just as an FYI, as of this afternoon, I’m now able to preview scenes. I just can’t view published files.

 

Tim Danner

Adding my entire production folder, with all of my published Storyline files, as a Trusted Folder Location in the Trusted Location Settings of the Flash Player Settings Manager, thankfully, worked for me. Now, I can view published content on my local machine like always.

Edit: Should clarify that this worked in Firefox and IE 11, but not in Chrome.

Ashley Terwilliger

Hi Sue,

I certainly can understand that set up - and we've seen issues with file corruption and other latency behavior when working off a network drive, so that's why I bring it up. If they are not newly published it does sound like something may have changed within the environment - so please keep us posted what your IT team is able to share as well.

In terms of not being able to preview (although it sounds fixed?) did you also confirm it's the latest update of Storyline 2 Update 10? 

Ashley Terwilliger

Hi Tim,

Did you look at the link that Pierre shared previously as well? Is that where you were changing the settings? If you're able to view locally in IE11 and Firefox, hopefully that's a good go forward until you're ready to upload to your intended publish environment. Please keep us posted if you find out anything else! 

P-O E

The Flash Player Settings Manager was a very good remedy when I need to review the published content without having to publish it to the LMS. But for others that shall review the content from a network storage area this is not acceptable - it is both cumbersome and a matter of safety (to tell someone to add make security settings on their computers ...).

Setup: SL2 Update 10, IE 11.0.33, FLash 23.0.0.162.

Lynn Kepford

I'm not able to get this to work. Following the instructions on the site referenced above, I was unable to add a folder. I added the story.html file for the current project, but still was unable to play. I'm not sure what's going wrong. Many of the users of this project will be viewing on local machines. Publishing as a CD seems to work, however I'm not sure if this technique will result in other problems for users as some organizations don't allow the sharing of exe files. 

Pieter Uytterhoeven

Hi, experiencing the same problem.
The solution proposed is okay for a temporary workaround, but not workable as a long term solution. 
It's impossible to tell customers - "hey, could you adjust the flash settings etc for people who want to watch it offline". I would also like to know if there is anything being done to remedy this serious problem.
Thanks in advance.

(for people who are stuck and have windows 10 - offline play still works in edge - for now)