Font Change within a Text Entry Field

No matter what i do to the font and font size of the text within a text entry box, it always reverts back to the Articulate font, 12 point.

I've already noticed there are two ways to edit the font: You can click on the box and change the font, or you can edit the text and then change the font.

I've done both and every time it reverts back to Articulate 12pt.

Is this a bug?  What's the work around?  Highly annoying!

195 Replies
Leslie McKerchie

Hi Justin!

The issue that Daniel mentioned above has been reported to our QA Team.

Here is the previous response to the thread mentioned above:

Leslie McKerchie

Hi Marie!

I popped in to check on Daniel's issue for you and it was reported to our QA Team for review. His issue is related to the slide size of his project.

WORKAROUND:
1. Slide size should be below the following resolution:

Lower than 760x570 for 4:3 aspect ratio.
Lower than 970x546 for 16:9 aspect ratio.

If your issue seems different, then I would encourage you to share as well.

Justin Lambakis

Hi Leslie,

I am not having the same issue as Daniel, I am having the same issue as the original post. The font size of my text entry field reverts to the default text size when you click on it (in it or on it) on the stage, not in the published version. I made a note in the Story file I attached previously explaining the problem. Any solution for that problem?

Thanks~ Justin

Ashley Terwilliger

Hi Justin,

I did not experience that when testing your file - it stayed at 8 Open Sans as the option. I do see that our team is aware of an issue where the font size changes back to 12 when you're seeing that change when using a different slide size than the standard Story Size (760x570 for 4:3 aspect ratio or 970x546 for 16:9 aspect ratio). But since I didn't experience it on your file, I suspect you're not using those story sizes. 

Justin Lambakis

Hi Ashley,

Thanks for the feedback. I'm confused, are you saying that 760X570 is the 'standard' Story Size? I have never heard that before. New projects always start at 720 X 540 so I thought that was 'standard' (default). I used 720 X 540 for my test file after reading some of the responses in this thread. Anyway I just changed my test file to 760X570 after reading your repsonse (and attached to this reply). Same issue. Also note that this happens EVERY single time I click outisde the text entry box, it's not a sparatic issue. Curious why you don't expereince the same behavior. 

This is a huge pain pain point for me as I'm constantly going back and fixing each one of them when they appear in testing or in the classroom...and when it's already on the LMS, of course that means re-publish, re-upload,, etc just for a little bug.

Can you have other folks try to test my file on different computers and see if they experience the same issue. 

Thank you!

~J

Ashley Terwilliger

Sorry Justin - looks like a typo in my previous reply about the story size.  720 X 540 is the default 4:3 size. 

I tried your test file again, and it still worked normally for me - can you tell me a bit more about your system set up so that I could try it in different environments? I work mostly in Windows 8.1 with Office 2013. Also, are you on the latest update of Storyline 2, update 5? Have you gone through the repair steps?  Also, if you could tell me the exact steps you go through to see this or even record a video of the behavior, I can try to follow those exactly. 

Ashley Terwilliger

Hi Brian,

You'll see I haven't heard back from Justin, so I'm not certain how he's able to see/replicate this each time. If you're able to check into all the steps above in terms of working locally, repairing, etc. that'll be some good first actions. If you could share the steps you go through and a sample file, that would be helpful for us to continue investigating. 

Rory Lavender

Most of our eLearning involve computer simulations, utilizing text entry fields. This font flipping is adding to our development time and frustration as well. We are grateful for the proposed work arounds but find it a shame that a proper solution has not been found as yet. There are too many people experiencing this for it to be written off as "unable to replicate" or the pat answer of making sure you are working in the right environment, etc. 

Ashley, perhaps you have a best practice that you would like to share as to how are you getting this to work as you expect? What font + size are your stories defaulting to for text entry fields? If you are having to change this, how exactly are you doing this?

I've seen at least 4 workarounds:

  1. click the text box to get a highlighted solid line, change the font, then click outside the box
  2. update the text entry field and lock the text entry
  3. set the default text box (this doesn't work for me at all)
  4. type in the font size and then press the enter key

None work on a consistent basis. Just when I think a solution is working, it stops working. #4 seems promising at the moment! Here is hoping!

It appears that Cory shared a story over a year ago. Was this sufficient for the QA team? Do you need more samples? Please advise the latest of this problem. Thanks.

 

 

Alexander Salas

Hi Leslie, 

I now have contracted the Text Entry change of size font syndrome : ( 

I'm on the latest SL2 update and working locally on my PC. Have you guys gotten any closer to a fix on this? My issue is the text shrinks on preview and it's only the field label text i.e. Type your Text Here

I originally wrote this as having a fix but, no cigar /: {

Ashley Terwilliger

Hi Rory and Alexander,

As you can see this thread has a few different issues in it - one of which as Leslie mentioned was reported to our QA team in regards to the font changing in a text entry with the workaround of using the default Story Size (760x570 for 4:3 aspect ratio or 970x546 for 16:9 aspect ratio). I don't have any additional information to share at this time, but this thread is marked for update in connection with that QA report.