Freeform question issue: items not appearing in center

Y'all,

I made a freeform question in which users get to drag n drop upcoming items to the right box. 

In the drag & drop options (design tab) I've set the drag item options to

[X] reveal drag items one at a time

So the items come up one by one. 

The items contain also an animation 'grow' 

Problem: The items don't come up from their original position. When replaying, they do but initially they don't...

Anyone familiair with such an issue?

15 Replies
Ren Gomez

Hi Peter,

Thanks for reaching out. I'm sorry that you ran into the issue where drag items that have an animation don't reveal properly when choosing the option to reveal one at a time. 

We have reported it to our team, and continue to keep an eye on it to evaluate how many customers are impacted and what impact it has on courses.

The current workaround would be to remove the animation from the objects. I know this isn't ideal, but we'll be sure to jump back in here to share when any progress is made!

Peter vanderslikke

I have to get back to this (should have checked first) but... the current workaround did not work for me. I removed all animation from the object but they still don't turn up centered... 

However the trick that did it for me was to turn off shuffle answers (at the design tab). That seemed to be conflicting with the drag n drop option: 'reveal  items one at a time' in which you have to set the appearing order thus conflicts with shuffling. Am I clear enough? ;-)

I even could turn on the animations back on.

Hope this will be helpful for other people running into this.

Kelly Ketelhut

Hi - I am having the same issue where the 'reveal drag items one at a time' isn't working on my freefrom drag and drop option. The slide functions properly except the reveal one at a time. I can still complete the desired drag and drop without revealing one at a time however it is a bit messy. I would really like to use the option....any idea on what's up?

Peter vanderslikke

Hi Kelly, what exactly isn't working? The revealing one at a time itself? Are your states correctly set? (I came from there, having set the initial states to 'hidden')...

What do you see when the reveal one at a time is off? And what if you play around with the order? Are your items currently overlapping and what happens if you give them their own spot?

Kelly Ketelhut

Hi -

The reveal one at a time option from the 'drag and drop options' menu isn't working.

Object initial states are all set to normal, have tried with objects overlapping and when they have their own spot, I have tried reordering the objects in the 'from view' drag item column as well. No results. 

When I preview the slide, all the drag items are hidden except one. I drag that item to a drop target and the next drag object does not populate. 

If I turn off 'reveal one at a time' the drag and drop interaction works just fine. 

 

 

Wendy Farmer

I don't think I'm following

There are no drop targets set in the form view - I added the top two.

See this Peek

So when I drag the first wine glass to a hot spot then the next wine glass is revealed - as expected...it's not showing the layers but the reveal one at a time works but only when you have something set up in the form view for the drop target.

I'm not sure why you have all the hotspots - could you just have one or am I missing a piece of the puzzle

 

Kelly Ketelhut

I did have to delete some of the information for confidentiality reasons. So part of the puzzle is missing. 

The purpose is to have a multi correct drag and drop interaction, that is why there are so many hotspots. I have created this activity before and the reveal one at a time worked, but it isn't now. The previous interaction is set up the exact same way but the click to reveal is working. I had heard rumors that this was a problem as a result of the last update and was wondering if there was a fix. 

Thank you for looking at this for me.