Freeform quiz allows Submit without selecting answer

Dec 13, 2018

I'm having an issue with one of my freeform quiz questions. When I am previewing, I select "Submit" without choosing an option, I get the prompt that says "You must complete the question before submitting", I click Ok, then it progresses to the "correct" feedback layer.

I checked all the settings and everything looks good (I have other similar quiz slides with the same exact setting and everything matches and works fine). Before I consider this a corrupt slide and redo it, anyone else experience this behavior? I'm wondering if it has anything to do with the recent update.

*I also published the scene to Articulate Review and same behavior.

9 Replies
Megan Creegan

Hi Leslie, I just tried publishing from my Windows PC and it worked fine. The issue happened in Windows (same version) but I was running it through Parallels on my Mac. I've experience some unexpected behavior when doing it from there. So for now, it's fixed. Thank you for reaching out!

Also curious to hear if anyone else comes across issues while working in Parallels.

Javier Serrano

Hi Megan,

I am having this same issue now. I am running Storyline 360 on a Windows 10 PC. When previewing the quiz slide, I can click the submit button without answering to which I get that same Invalid Answer, You Must Select...but when I click Ok to it, Storyline plays both the Correct and the Incorrect audio files associated with the Correct/Incorrect layers...Have not figured it out how to make this go away. Audio should not play at all until a selection has been made and the submit button clicked. Any other ideas?

Callie Verderosa

Hi Leslie and Megan,

I am having this issue on two projects I am working on - and when searching in the community for an answer or advice on how to move forward, I found this thread. I am working on a PC (Dell).

On one project, I have two free form quiz questions that allow me to press the submit button before I click on anything (both are drag and drops) on the free form quiz slide. - and I receive the "incorrect" layer I've incorporated (on both).  I thought maybe this was just the standard way these free form slides work, but two other drag and drop free form questions I have require me to at least move one drag and drop item before I can submit. I get the standard "you must answer this question before moving forward" message. 

Any idea why this might be happening? Especially since I am not working off of Parallels?

I have another project that is doing this as well. 

Lauren Connelly

Hi Callie!

I'm happy to help! It looks like there have been workarounds discussed in this post that might be worth checking out. 

Since you see this error in multiple projects, it would be helpful to see your course in action. Would you mind sharing your project with me? You can attach it to this discussion or share the course privately. I'll let you know what I find!

This discussion is closed. You can start a new discussion or contact Articulate Support.