Html5 output giving black screens

Hello,

     I am having the issue of getting black screens in html5 when i make "View Mode" and "Try Mode" sections in my lessons.  This only happens when the screen transitions to a light box slide.  Once this has happened, the screen will stay black until the video portion is over.  This is obviously an issue with Articulate and html5.  Has this been reported yet?  I cannot offer these lessons in html5, which is not good, if this issue cannot be resolved before we launch.  

     I have attached a video to show you what I am talking about.  The first part is the lesson in the html output.  The second part after the completion slide is the html5 output with the black screens.  I have tried republishing and checked other lessons for this and it occurs.  I am using Google Chrome for both instances.  Hopefully, we can get this resolved soon.  Thanks.

-Brian

11 Replies
Christine Hendrickson

Hi Brian,

I apologize for the trouble.

I do see an issue that was reported, and that will be repaired with the next update, that's specific to HTML5 and with video playback.

I've added this thread to the report, so I can share an update here when the update is released.

In the meantime, it may help to try using a layer. The issue is specific to videos, however, and not just specific to lightboxes. If the layer issue doesn't work for you, please let me know, so I can add this information to our report.

Again, sorry for the trouble. Hopefully we'll have an update on this soon!

Best,

Christine

Brian Seaman

Hi Christine,

     Sorry for the late reply.  I will see if your suggestion works.  At the same time, we are not releasing our lessons until the end of July so I might just wait for the update to fix my problem.  I know you don't have a timetable on the next update, but I am feeling good about it being before the end of July.

-Brian

Christine Hendrickson

Hi Brian,

No problem whatsoever on the delay - things happen :)

I certainly hope you're right about July, I know many (including myself) would be very happy to have access as soon as possible. Updates are always exciting and I know we have some great fixes on the menu. 

In the meantime, please let me know if I can be of any assistance.

Have a great day,

Christine

Brian Seaman

I am following up with this post in that we are launching our lessons at the end of the week. Is there any possible date for the next update to fix the black screen problem? Adding the extra layer works sometimes and sometimes it does not. I was really hoping that the update would be ready before or shortly after launching these lessons. Thanks.

Christine Hendrickson

Hi Brian,

I just double-checked the issue and though it's currently flagged as critical by our QA department, this doesn't impact the time frame for the full update release itself. This really depends on all of the other fixes that are currently going into the update and it won't be released before all of these fixes have been tested.

I'm afraid I don't have an estimate for the update at this point, but as soon as we in support get word of this, we'll be sure to share it.

I know this is causing some frustration for you and I sincerely apologize for the trouble and delay.

We'll try to keep you as updated as possible.

Best,

Christine

Brian Seaman

Hello,

I updated to the latest version of Storyline because it was mentioned that this issue would be fixed. I read the release notes and did not see this issue fixed or missed it. I published two lessons and still am having this problem. Please see the above video from the first post. I am happy to share a .story with you in private, if needed. Thanks.

-Brian

Ashley Terwilliger

Hi Brian,

Sorry for the delay in getting back to you. I checked into the report that was filed with our QA team that Christine linked this thread too although as you mentioned I do not see it in update 6 (you can read all the release notes here.). With that in mind, I'd like to see if you'd be able to share a copy of your .story file with us, and you mentioned sending it in private so please feel free to direct it to our Support engineers here. If you've already sent it along, please let me know the case number so that I can follow along.

Thanks!

Michael Bellis

Hi I was wondering whether this was ever resolved. I'm getting a similar issue on an Android Galaxy tablet (the latest) all the minimum specs are met, I've checked. The problem is that for a couple of seconds before each video plays I'm getting a black screen. I tried re-encoding videos from the stoyline output in Handbrake (free video editing tool) and managed to get the time down slightly but haven't completely removed it. I also saw a post not specifically about storyline but about videos on Android devices and saw a suggestion that a Poster frame can help mask the black screen delay before the video plays, I tried adding the poster frame for one of the videos, I can see it in the output, but the black screen delay still follows the poster frame.

Ashley Terwilliger

Hi Michael,

The issue mentioned here wasn't a part of Storyline 2 and the Android display, as it was in reference to Storyline 1. Storyline 2 came out in September of last year, per the release notes here. 

The issue you're describing has been reported to our QA team, in that it occurs when using a screen recording video and viewing the HTML5 output on your Android device there is a blank/black slide inbetween the screens or as the video changes. I don't have any information to share in regards to workaround although it seems to be specific to Android and the Chrome browser - so you may want to look at publishing for the Mobile Player (additional information here on how to ensure it'll work with your LMS) and/or using an iPad. 

I'll include this thread in the report filed with our team so that I can share additional information with you here once it's available. 

Ashley Terwilliger

Hi Ahmed,

This discussion is quite a bit older, so it seems unlikely that you've run into the same thing as it was for Storyline 1. I'd start by checking that your Galaxy tablet is running a supported Android OS  per the Storyline 3 requirements and you're viewing the courses in the Chrome browser. Also, do you know what version of Storyline you're using? Storyline 3, build 3.6.18134.0 is the latest. 

Let me know if you're able to check into those pieces, and then it may also be something where we'll need to take a look at your .story file.