Hyperlinks not working after importing translated text

I'm working on storyline files that have translated text imported into them. The content has many hyperlinks and I'm facing issues with those hyperlinks. When I run the story file (after publishing) and hover over the text having hyperlinks, multiple lines of text, having different hyperlinks, get clubbed together and open just one link. I deleted and rebuilt the hyperlinks, but the issue remains. Howevever, the same hyperlinks work fine on the source file (English version) that I used to create multiple versions.
Any suggestions on how to make the hyperlinks work the multiple versions I've built in different languages?

21 Replies
Tess Curnow

Was this problem ever resolved? I have a similar problem in Storyline 2 (latest version). After importing the translated text, none of the hyperlinks work. The triggers are still there, but nothing happens when I click on the hyperlinked text. In some, but not all, cases, the hyperlinks are within a scrolling panel of text.

I've built a single page test file and tried exporting then re-importing the text. In this example, the first hyperlink didn't work but the remaining 2 did. I had altered the text in the sentence before the first hyperlink, to simulate translation, but left the remaining text unchanged. Does editing the text and re-importing it break the triggers? 

Nagendra Hasilkar

Ok.. just two cents from me. Not sure if this is what Storyline requires to be able to work correctly; but I tried placing both the files (i.e. .Story & the translated word file) at the same location before importing. Also shortened the filename of the word file. These two steps made huge difference to the .Story file after the import. Though not all the hyperlinks worked, but most of them were in line.

Ashley Terwilliger

Thanks Tess for sharing the .doc files here. I tested all your files, and then tested my own set up as well and was able to replicate the problem. I'm going to report this to our QA team for additional review and will share any information here with you once available. I cannot offer a time frame in regards to a fix or an update, so in the meantime it seems trying to insert a hyperlink again in that spot allows it to work correctly. 

Leslie McKerchie

Hi Johann and welcome to E-Learning Heroes :)

Are you experiencing this issue with Storyline 2 and multiple hyperlinks in a text box? That's the issue I'm seeing reported for this thread.

I do not have an update to provide, but if that doesn't fit your issue, feel free to share some details and your .story file for us to take a look.

Katie Riggio

Hello there, Terry!

I replied to your other post, where it looks like you're facing the first issue. I'm having trouble recreating the experience in Update 40.

Are you comfortable with sharing the project file from your screencast for troubleshooting? You can share it privately with me through this link.