Jump to File

I have created a Storyline file that has a button on one screen that when pressed needs to display a PDF file.  I have created a Trigger for the button to 'Jump to ULR/File'.  In the wizzard I have selected the file from my network drive folder, however when I try to use the check feature I get the following message:

Can anyone tell me what I am doing wrong?

Many thanks in advance.

Helen T

9 Replies
Christine Hendrickson

Hi Helen,

Right off the bat: Network drive

Your files need to be on your local drive, if at all possible. Work on your local drive (your C: drive). Working on a network drive or a USB drive can cause erratic behavior, including file corruption, loss of audio, and other unexpected behavior. You should also make sure the directory path to your project files and your published output is less than 260 characters (for example C:\Articulate).  Avoid using special characters, accents or symbols in your file names. From the screenshot you provided, I can see there are a couple of underscores in the file name. You may want to try removing those, as well.

Additional information regarding "Naming Files, Paths, and Namespaces" in Windows operating systems can be found in the following Microsoft article.

Also, you may want to take a look at Jeanette's post on Launching a PDF via button.

Let me know how it goes, Helen.

Thanks!

Helen Tarbox

Hi Christine

I  have removed the underscores from the file name and moved the .story file & PDF to the 'My Articulate' folder in My Docs.  However I am still unable to 'check' the file or view it when published for 'Web' and put on our server.

Here is a screen shot

Can you suggest anything else I could try?

Many thanks in advance.

Christine Hendrickson

Hi Helen,

Thanks for getting back to me. Are you able to share the project's .STORY file here, or the PDF? I can try to see if I can get the file to launch properly in a course, if you'd like. If the file is too large, or you want to keep the content private, you're also welcome to submit the files to us in a support case. If you do submit a support case, please share the case number with me.

Thanks!

Helen Tarbox

Ok, what I am about to enter next may seem very obvious to some people, but it was not to me...

When I published my file for 'Web' and copied the files onto the web server I automatically opened the 'Story.html. file from Windows Explorer.  When doing this I found that the PDF did not open.

If I take the time to type in the long web address (pointing to the 'Story.html' file) the PDF file does open.

I never realised that there would be a difference between the 2 ways of opening a .html file, but I guess there is. 

Ed Crane

Having a similar issue.

  • When I open the trigger and click the green check mark, it opens the window of the folder in which the target files reside.
  • When I preview the file, the text shows a being clickable/linkable.
  • When I publish the file (either locally or to the server), the text is static...cannot be clicked on.
  • The path is C:\Articulate\file name. It is less than 256 characters.

Edit: I'm publishing this to a non-LMS server but using the LMS publish settings  - this is so the stakeholders can review prior to publishing to the LMS. would that make a difference?

Ed Crane

It appears I found my answer...The text I have with the link is on the same slide as a Web Object. When viewing the course, the web object appears to only take up a part of the slide, so the text at the bottom is visible and has the white background behind it.

In reality, the web object covers the entire slide, which is why the link won’t work (and why the Resources menu appears behind the video).

I've resized the web object and can now put the text with the link underneath it.

Thanks!