Jumpy text boxes in Storyline

I'm having three issues in Storyline with text boxes, and I looked but haven't found solutions on the forums:

1. Once I've typed into a text box, if I click it later, it jumps around a little, and the text often gets smaller by a point or two. If I click outside the box, it goes back to normal size.

2. While typing into a text box, the spell-check red wavy line shows the whole time, like I'm misspelling a word. On every. Single. Letter. I think that's a bug.

3. If I make a PNG or JPG banner in Photoshop and center a text box over it in Storyline, perfectly aligned, that text box will always be too high in the banner once previewed or published.

If I've missed the answers in the forum, my apologies--it's not for lack of trying! Thanks. (Please see below for examples of Storyline moving text boxes up in Preview or Publish.)

20 Replies
Margaret Jamal

I am also having a number of problem.  The text box goes goes off the screen.  Also the page keeps freezing up.  I have not been able to complete much of anything.  It looks day one of my 30 day trial would be spent with restarting the application, if I could handle the frustration that long.

The video makes the package appear so wonderful, but I can't get to first base.  Help me out please!  MJ

Phil Mayor

Hi Charlie, Point 1, normally happens if you are not working at 100% zoom.  When editing the text it appears slightly smaller then when you click out of the box it springs back to its display size.  At the moment it is best to work with text at 100% zoom to stop this happening.

Not sure about your other issues, sorry

Charles Thompson

Hi Phil,

Thanks for the reply. You're correct! At 100% zoom, the text doesn't jump or resize. However, I'm working on 2560 x 1440-pixel monitors. Zooming out to 100% resolution means I get to work on a slide that's only six actual inches wide on a 27-inch screen (please see 100% and Fit Screen zoom examples below). I'm sure you would agree that I can expect text to stay in one place while I work on it, at any zoom level. I don't know if this counts as a feature request or a bug report. Which should I do? I know how to do feature requests, but not bug reports.

Jennifer Boettcher

Thanks for bringing this up, Charles!  I was going to submit a new thread to ask this very same question about "jumpy text boxes" but found this answer first.  The 100% zoom worked for me too - though I was having the opposite issue where I was viewing it at 90% originally, rather than 180% zoom like you. 

Though, since I am having this problem almost a year later, I wonder what the status of the bug/feature request is? 

Will Findlay

Another thank you for bringing this up! It has been driving me crazy the way the font size kept shrinking when I edited a text box and thanks to Phil's response I am now viewing slides at 100% instead of 80% and the font is no longer shrinking when I go to edit the text.

Another strange thing that happens to me is that sometimes when I import a PowerPoint slide, the original formatting of text in the text boxes is suddenly lost (and when it occurs is unpredictable to me). Then, when I click inside the text box, tit expands so that it is as wide as the longest sentence in the text box, so I have to manually change the widths of all my text boxes.

Curtis Kynerd

I have the same issue as you are describing Will.  I can save the file and come back to it later, and the text box has expanded to the longest sentence in the text box.  But I have now experienced a new issue.  I saved the file, and later returned.  Now my text boxes are sized to the correct size, but the text is still as long as the longest sentence.  This time, because the text box boundaries are set properly, I don't have any ability to resize the box to restrain the long sentence anymore.   This is the first time it has happend to me. 

The text box instability is really frustrating.  You can set everything like you want it to be, save and then come back later and have all the boxes expanded again.  I really like Storyline, but some of these "little" quirks sure need fixing. 

Mary Schoeller

I realize this is an old thread, but just checking to see if this is still being worked on. I do have the latest update to Storyline 1, and the text jumping when not at 100% still happens.

Also, we are considering purchasing Storyline 2, but would like to know if this still happens in that version before we do go ahead with the purchase.

Thanks,

Mary

Charles Thompson

Hi Mary,

It's been a long time since I circled back to this thread. I started the thread more than two years ago, and it appeared that the issue would never get fixed.

I'm happy to report that I'm using the trial of Storyline 2 (purchased over the weekend, and waiting for a key), and I'm not having the problem at all!

You should try the free, full-featured trial of Storyline 2 to see if it works as well for you. Be advised, files created in Storyline 2 cannot be opened in Storyline 1.

Mary Schoeller

Hi Charles - 

Glad to hear that you're not having the issue in Storyline 2! I will have to give the trial a try.

I am guessing this will not be fixed in Storyline 1, so thinking our only option will be to upgrade. I know there are other great things in Storyline 2, so we'll get other benefits too.

Thanks,

Mary

Antonio A

Hi,

I am working in SL2 and i have the text of the answers of some quizzes jumping when mouse over. I noticed that when the answer is just 1 line of text it doesn't jump and when the answer is longer (2 lines of text) it jump, not in all cases but most of them.

I am attaching a file with the problem...

Thanks for any help,

Charles Thompson

Wow, that's a bummer. I saw your file, and the two-line answer indeed jumps! I tried to duplicate it in my own files, but didn't have the issue.

On a separate note, you have a seekbar in your quiz (generally, there's nothing to seek in a quiz, and it confuses the learner into thinking they're timed). And your first slide is set to auto-advance to the next when the timeline ends. It will likely advance before the user gets to answer the question on Slide 1.

Antonio A

Hi everyone,

I was able to fix the problem doing the next:

Click to selec the texbox of the answer that was jumping when published and CONTROL+X  and just after that CONTRL+Z (It´s like i am going to cut the answer but I regret and go back with control+z) the question get replaced below the others by itself (do not know why)

I do not know the reason but it worked for me. I think if you do CONTROL+X and after that CONTRL+V it work the same.

I am attaching an screenshot in how i selected the textbox of the answer to fix.