Layers on Master Slide show on slide preview but not on project preview

Hi! I hope someone in the community can help me with my SL2 issue.

I created layers on a master slide, and they work perfectly when I preview each slide. But when I preview the whole project, the master slide layers come out in a couple of slides but not in most. These slides have identical triggers, so I can't figure out why the master layers appear in some slides but not in others.

I did a test publish and the project preview version--with slides missing the master slide layers--came out. I tried importing the slides to a new file but still got the same result. I'm working from my local drive, so it couldn't be a network bug.

5 Replies
Tin Telesforo

Hi Wendy! It's a software simulation project, quite long, and might have confidentiality restrictions. So I just took the first five slides that show the issue. You'll see here that the light bulb (an object on the master-slide layer) appears on the first three slides and then no more. 

For this project, I built the master slide layers and used triggers such that the layers would appear over the recorded screens. It was quite complex and very tedious to copy-paste the triggers on each of nearly 100 slides, but I pulled it off. At least I thought I did, because the master-slide layers were there when I previewed each slide. But when I previewed the whole project, the master-slide layers disppeared in random slides.

Wendy Farmer

Hi Tin

I think the triggers for the variable on your slide master were contradicting with the triggers on the slides. 

I created a T/F variable (lightBulb) that you toggle on and off...I also added an off state to the picture on and only used the one pic of the lightbulb.

I then used the T/F variable on the slides to trigger the hint layer to show and reset the variable to false each time a new slide started.

I put the variable references on the screen so you can see when the variable changes.

I see you have just copied the hint layer from one slide to another and assume you will be updating with the correct info (took me a couple of tries to get it working as I was clicking in the wrong place - lol)

Anyway - see if it helps - here's a quick video of what I'm now seeing which I think it correct behaviour.