Next button not advancing

I have a course that has a video on slide 3. We want to make sure they complete the video before completing the course. I have the next button set to advance once the media completes - but it isn't advancing and clicking the next button doesn't do anything. So people can't seem to close out of the course and mark as attending in the LMS.

I have been playing with button and have even tried changing it to advance at the end of the timeline, still doesn't advance to next slide. I have had this work before, so I don't know why it isn't now.

5 Replies
Alyssa Gomez

Thanks for sharing your file with me, Karyn! I made a few changes and attached the updated file. Here's a summary of the changes I made:

  • I changed the state of the Next button to Disabled when the timeline starts. This will¬†indicate to the learner that they cannot click Next until the video ends.
  • I added a trigger to change the state of the Next button to Normal when the media completes.¬†
  • Assuming you don't want the learner to fast forward the video, I placed a transparent rectangle on top of it. This will prevent the learner from clicking on the seekbar to skip content. (You can always remove that rectangle if you don't need it.)

Let me know if you have any questions about those changes!

Alyssa Gomez

Hi Karyn,

Your next button was set to advance when the timeline ends. Since the timeline is over 20 mins long, it's possible that the learners were advancing the video using the video controls bar, which would cause the video and the slide timeline to become out-of-sync.

To prevent that from happening, it's best to set the next button to activate when the media completes.