Not Playing When Published to CD

Hello - I'm trying to publish a test for internal distribution, using the CD option in the Publish menu. After the publishing process is complete, I'm able to run the project using the Launch_Story.exe on my main computer, the one I used to create the project. But, I cannot get it to work on any other computers. I used the Zip process that displays after publishing is complete, to zip up the published files, then copied the zip file to my other computers, unzipped them, run the Launch_Story.exe, and on both machines a new blank window displays, and the project never loads/runs. Both are Windows machines, one is windows 7 one is Vista. Both have the current version of Flash player installed (I'm not sure if that's relevant). I don't want to send this around for internal review until I'm reasonably confident it will play on other employee's machines. Any idea what the problem is?

Thanks, appreciate any help you can give.

22 Replies
Andrew Hay

Hi Leslie - The project works on the machine I recorded it on, which is a Windows 7 32 bit machine. It does not work on a Windows 7 64 bit machine and doesn't work on a Windows Vista (32 bit I think). Those are the main differences in the environments, I'm sure there are others but I don't know what might be relevant. I've attached the output, zipped up using the Zip function at the end of the Publish routine.

Thanks for your help.

Leslie McKerchie

Hi Andrew!

Will the course launch if you utilize the story.html file in the output on the computer in question?

Are you receiving an error message or just nothing is happening?

It may be best to connect with our support team if we need to utilize this further. They have some additional abilities such as log files, etc that may be needed.

 

Andrew Hay

Yes, it does run, but I get the attached error first. If I click Settings in the error box, then it loads the project in my browser and I can run it fine. I checked through the settings and don't see what I need to change in order to let it run without getting the error. Also not sure if this error is related to why it won't run when using the story.swf. I'm guessing it is...

I don't get an error message when trying to use the story.swf. It just opens up a blank window.

I'll go ahead and contact support for more help. Thanks for your assistance.

 

Andrew Hay

In case anyone else runs into this, here is the solution that support provided, and it fixed the issue (running the project using the exe doesn't work) on both computers which were having the problem. On the first computer  I went through all the steps, then tried running the exe again and it worked. On the second computer I figured I'd check the exe after each step, to see which one solved the problem, and it was solved after running the very first step. Previously I had upgraded flash player using Firefox and Chrome, guess that was wrong.

1) Using Internet Explorer, upgrade Adobe Flash Player here: http://www.adobe.com/go/getflash

2) Clear your browser cache. You can do this in Internet Explorer by going to Tools > Internet Options > General > Temporary Internet Files. Select Delete Cookies and Delete Files.
3) Also in Internet Options, on the Security, Privacy, and Advanced tabs, reset everything to its default settings. There is a button on each tab to reset defaults.
4) In Windows Vista / 7, go to Start > All Programs > Accessories > Run. In Windows XP, go to Start > Run.
5) Copy / paste the following line of text (depending on your operating system) into the Run dialog box. Click OK, and delete the entire contents of the window (folder) that opens.

Windows Vista / 7:
"C:\Users\%username%\AppData\Roaming\Macromedia\Flash Player\#SharedObjects"

Windows XP:
"C:\Documents and Settings\%username%\Application Data\Macromedia\Flash Player\#SharedObjects"

6) Close all browser windows for the changes to take effect, and then test your content again.

Todd Tilk

I am having the same issue, but it is not convenient to run to 15 different PCs to do all this prep work before providing each person with the emailed zip file.  Has anything been done to resolve this issue on the back end in the 6 months since this post?  Is there a better way to test the training course before loading it on an LMS?

Andrea  Vasquez

I published a course to CD, saved it to a local hard drive,  extracted the files, and double-clicked the Launch_Story.exe file to play the course. It worked on my PC. When I replicated this process on my laptop, the course would not launch, but it turns out I simply needed to upgrade my flash player  http://www.adobe.com/go/getflash. Do you have a document that outlines system requirements for successfully launching a "Launch_Story.exe" file that was published for CD but intended to launch on a local drive (created in Storyline 2).