Odd Errors - anyone else experience this?

Apr 29, 2020

Hi all,

I've been working on a course that has, quite frankly, a few too many cooks in the kitchen. I'm the only one that has been working on the Articulate storyline file, but over the last 6 months I've built a "Welcome New Employee" course from scratch and then made change after change after change as different groups weigh in. Now I'm experiencing some weird issues:

Videos (2 of them) that previously worked fine no longer work IF you are not using a mouse. If you tab to the play button and press Enter or Spacebar to play the video, usually nothing happens. But sometimes it does work. There seems to be no rhyme or reason as to when it works or doesn't work. If you click the play button with the mouse it works fine every time. (Both videos are linked to rather than embedded). I was only able to make them work some of the time after I deleted the embed codes and reinserted the videos. The course must be 508 compliant so tabbing is required.

I have transitions set on some slides. In one case, I have the slides set to enter from the bottom, but they enter from the top. I was able to fix this by removing the transitions and then re-adding them. 

At one point all of the Next buttons stopped working, although they had previously worked fine. I fixed this by deleting the triggers and adding the triggers again - the exact same triggers as before. Now they work fine. 

Here's my fear - I am afraid that over time this course has been frankensteined together and now things are breaking down. The only way to fix these things seems to be to delete the item causing the problem, but as soon as I fix one problem the next one pops up. Now that the course is almost done and we are (finally!) no longer accepting feedback, do I need to just rebuild the whole course from scratch to make it work properly? Has anyone else experienced this with a course, where items randomly stop working?

3 Replies
Lauren Connelly

Hi Kristin!

I'd love to help! It sounds like the course was working well in the past, and now the snags are occurring! 

These errors do sound file-specific so it would be easiest if I could take a look at course. Would you mind sharing it with us?

You can either:

  • Attach it to this discussion by using the Add Attachment button
  • Share it privately using this secure upload link

Either way, we'll take and look and report back with our findings! 

This discussion is closed. You can start a new discussion or contact Articulate Support.