Open a local PDF file from Storyline ?

I have a PDF in my Storyline published folder:  /story_content/external_files.

I created a hotspot in Storyline and then created a trigger Jump to URL/File.

I clicked on the [...] button and selected the PDF file from the above folder and set it to open in a new browser window.

After publishing I am able to open the PDF when playing on my own computer but I cannot view it on other computers.  I notice the path in the trigger is pointing specifically to a folder on my hard drive.  So I tried shortening the path to the subfolders under story.html. 

story_content\\external_files\\myfile.pdf

Worked locally but not on other computers.

For grins I tried using forward slashed: story_content/external_files/myfile.pdf

No luck.   Is this a matter of syntax or am I not following the correct procedure for linking to the file in such a way that it will be published with the story and playable on any computer?

Can someone give me an idiot's guide to doing this?  Seems like it should be simple and fool proof.

Thanks.

7 Replies
Christine Hendrickson

Hi Ray!

Just curious, have you tried placing the PDF in the main directory, where the HTML file resides?

Take a look at this post. 

If this still doesn't work for you, can you share a PDF you're trying to attach? I'd be happy to test it out in a course and see if I'm able to get it working.

Also, let me know how you're publishing the course (Web, LMS, CD, etc.) if you can, please.

Thanks!

Christine

ray laurencelle

Hi Christine,

I tried what the post suggested:

1. used Jump to URL/File with a hotspot pointing to the PDF located in the same folder as my Storyline source file

2. copied the PDF to the folder where the story HTML is located

It still doesn't work.

I'm publishing the course for LMS.  I can't send you the PDF because it contains restricted information. But it is a normal PDF file that I can open with the story resources menu.  If I can open it there I should also be able to open it from a slide, no?

Christine Hendrickson

Hi Ray,

When you add a file to the Resources menu, the file actually becomes a part of the course - it's actually attached. If you link to the file, it's not quite the same thing, it's simply pointing to the file. 

What's the name of the PDF file? Are there any spaces, underscores, etc., in the file name? Try removing any of those extra characters, if possible, and see if that helps. 

I totally understand if you don't want to share the file publically for testing. However, if you'd like, you're certainly welcome to send it to us privately. Any information sent to us will remain confidential. 

Thanks Ray!

Christine

Leslie McKerchie

Hello Rahul and welcome to E-Learning Heroes :)

Christine does not make it back to the forums very often, but I'd be happy to help you out here.

It sounds like you'd like to be able to display the pdf in the slide, is that right?

Check out this similar thread and that should help you out with this task.