Open questions/essay through Storyline in Moodle, can it be done?

Hello,

 

We have an issue with the reporting of open questions/essay questions in Moodle (version 2.7). Apparently there is a limitation of 255 characters in data that can be shown in the "cmi.interactions_N.student_response" field. All extra data goes into the "cmi.suspend_data" field. This is unworkable for our customers. 

I know that you can make open questions/essay questions directly in Moodle but we do not want that, everything has to be in one module.

I have tried to raise the limit of the field by changing "CMIString4096 = '^[\\u0000-\\uffff]{0,4096}$';" to "CMIString4096 = '^[\\u0000-\\uffff]{0,40960}$';" and "CMIString256 = '^[\\u0000-\\uffff]{0,255}$';" to "CMIString256 = '^[\\u0000-\\uffff]{0,2550}$';" in the "mod/scorm/datamodels/scorm_12.js.php"-folder.

We are using SCORM 2004 because we also need the question text in the reporting (with SCORM 1.2 the question text does not get exported). We are also aware that SCORM 2004 is not fully supported on Moodle but that is not the cause of this issue since we have tried with both versions. All the settings in "plugins/activity modules/SCORM package" have also been tried.

 

Does anybody know of a solution to make the "cmi.interactions_N.student_response" field bigger? 

 

Kind regards,

Sander

 

23 Replies
Dan Marsden

In Moodle 2.7 we added a setting under admin > plugins > activities > SCORM called "Enable SCORM 1.2 standard mode" - which you can un-check and it will allow the SCORM player in Moodle to accept a higher character limit (64000 chars) but you will also need to adjust your SCORM packages as the SCORM package itself usually truncates the data before it sends it to the LMS to prevent errors. Someone else in the community here may be able to help you do this for Articulate packages.

 

Yang Yang

I have the same issue with the essey question in AS2 and have asked the LMS team to untick the "Enable SCORM 1.2 standard mode". However the result is the same as Moodle only record 255 characters even in the Excel export. I have also tried to publish to 2004 and Moodle did not record the response at all (blank in both report and excel export). Any suggestions?

Hamish Dewe

This can be done, but it's a little hacky.

There are two parts to solving this problem - you need to tell Moodle to accept larger amounts of data by unticking 'Enable SCORM 1.2 standard mode' but you also need to get Storyline to stop truncating the responses. In the file /lms/ScormFunctions.js there are four places where the truncation happens (lines 855, 862, 919 and 926 on my version). If you comment these lines out after publishing but before zipping, Storyline will send the full text.

You can make this the default behaviour of your Storyline install by editing the master copy at "C:\Program Files (x86)\Articulate\Articulate Storyline 2\Content\lms\". If you're going to do this, make sure you have a backup of the original file you can swap back in. Just in case.

An example of the edited file is attached.