Pause layer not working second time around

This is frustrating.  When running a screen the first time through everything works fine.  The sequence stops when the pause layer is activated and resumes when it's supposed to.  HOWEVER, when returning back to the screen (clicking back and then forward to return) the pause layer will not pause the timeline like it does the first time through. The layer image appears, but the pausing of the timeline is not happening like it does the first time through.  Yes, it's set to 'reset to initial state.'  I've tried the other options as well.

I've tried every possible workaround and nothing seems to work.  Any ideas?

5 Replies
Rebecca Fleisch Cordeiro

Howdy,

Not sure why it's not working without seeing it. Just tested here and things are working OK.

2 slides, the 2nd one has the media on it.

I DID have to add an extra trigger on the media slide to Play media when the timeline starts. This was to accommodate this situation: IF the media had finished playing while the pause layer was still active, things didn't work properly when clicking to go to a previous slide and then returning to the media slide.

Perhaps you could upload a couple slides for the community to take a look at.

Mark Cairns

I've been able to reproduce this bug consistently.

Please go to this link and follow the on-screen instructions. 

https://dl.dropboxusercontent.com/u/18950612/Pause%20Test%20output/story.html

I've attached the SL1 source. The same issue occurs with SL2.

Any help would be greatly appreciated.

Ashley Terwilliger

Hi Mark, 

I took a look at it and saw the behavior you're describing, and I wonder in regards to the pause behavior - if you'd set the slide to "resume saved state" would it accomplish what you need? As then, when the user revisits the slide they're able to pick up where they left off. 

I also do see an issue reported to our QA team for SL1 in regards to this issue with the pause behavior being on the slide master - instead of using the pause method detailed here (similar for SL1 and SL2). The current workaround for SL1 is to enable the "hide other slide layers" property on the layer that pauses the base layer, but I don't see this issue yet in SL2 so I'll share the example file you created with our QA team. 

Mark Cairns

Thanks Ashly,

Setting the slide to "resume saved state" or "hide other slide layers" isn't an option for my purposes. However, I was able to get it to work once I checked the "hide other slide layers" on the "Pause" layer in the slide master. I'll explore this option a bit more in SL1. 

I was able to get it to work in SL2 if I used the new "Pause timeline" and "Resume timeline" actions. (without having to "hide other slide layers").

I've attached the working SL 2 version if anyone is interested.

Thanks for your help!

-Mark