Preview Works but Publish doesn't result in success

Hi,

Major problem.  I've got a 238 slide project.  When I preview it works fine.  When I go to publish it (even just the HTML version) it goes through each slide and then jumps back to the publish form rather than yielding the "Complete success" as other times.  There is no error message so I have no idea why it didn't publish correctly.
Does anyone have an idea of what's up?

Thanks,

5 Replies
Ashley Terwilliger

Hi Ted,

First, can you confirm you're publishing to a local drive and what update of Storyline you're using? There was a known issue with publishing that was fixed in update 4. 

Also, does the publishing seem to stop at a  particular slide, or does it progress all the way to slide 238 in the publish window? Can you try importing it into a new Storyline project to see if there was something with that one file? Additionally, I'd check a new file (just a few slides with shapes or images) and see if you're able to publish the new file.

Let me know what you're able to determine after checking in to those. 

ted hildebrandt

Okay,

I've got the last update.  What I'm doing is there are three scenes: Learn, Drill, Review.  I just imported a ton of

questions for the drill.  What I did is deleted the "Drill" scene and did a publish on the Learn and Review scenes

and that worked fine.  Now I'm going to delete the "Learn" and "Review" scenes and see if I can publish just

the "Drill Scene"  if that works then (can I import a whole scene as a scene?)  Then I'll eliminate pages and

whittle it down to the slide where the problem is and then scope that out in detail.  Long process with so many

slides but hopefully that will isolate the problem.  Can I import a scene at a time? I've imported slides before.

Thanks this really threw me for a loop.  Crashed 3 times and I had to run off to a meeting. 

Let me try this isolating technique and see what I can come up with.  Thanks!

Ashley Terwilliger

Hi Ted,

Yes, you could import a whole scene and then choose it's destination (either Current scene, same as imported project, or new scene), you'll just want to select all the scenes in that slide, or if you've included it in it's own project you could select all the slides in that project. 

Keep us posted and if you need anything else just holler! 

ted hildebrandt

This is crazy.  I took it down started eliminating slides to find out which one was giving trouble in the "Publish" mode.

I restarted Storyline and tried to publish the original big project and the crazy thing published correctly.  I have no

idea what happened.   Another problem I keep having is when I'm saving things working with 238 slide project it tells

me (if I don't save for a while) that I don't have enough memory and to shut down other applications.  I've got 12 gigs of RAM

and 3 tb of hard drive so it is hard for me to see that it is out of memory.  What's up with that? 

These are minor things as I am really enjoying this program and it has made development so easy and enjoyable.  Best ever!

Ashley Terwilliger

Hi Ted,

It's possible that by pulling all the elements out and importing into a new project resolved any lingering issues or corruption. I'd recommend saving a back up copy of this file in addition to a version you're working in. In regards to the memory issue, it definitely sounds like you have enough memory, but I'd also recommend checking what other programs are open while you're working on Storyline, and if this is a very media heavy course that could be eating up a lot of memory as well. I've also heard users report that running Storyline on the 64-bit version of Windows helps as it handles memory better.