Print functionality not working on a specific LMS

Hi,

We just published a Storyline 2 course in our LMS. At the end of the course is a certificate that allows the learner to print. The print functionality works fine on our LMS. I tested the functionality on my printer and it worked fine also. After publishing, I sent the files to an external hosting service who will be uploading the course to their website. They tested it and the certificate prints only when the page is right-clicked on, the print button does not work. The web developer mentioned that the print functionality was not set up properly on the page and asked me to fix it. I was under the assumption that because it works in our LMS and in preview mode, it would work on any system. I don't know what could be wrong with the set-up; I'm keeping my fingers crossed that you will be able to help me.

Here's the reply the developer sent:

Having tested a bit more, the issue appears to be related to the print settings of the page. If I do a right click on the certificate and then select print, it does display and print fine (but with the menu options). This tells me that browsers can display the certificate but the page is not set up properly for printing. Developers should be able to fix that.

I included two screenshots of the triggers/javascript.

Thank you for your help.

6 Replies
Brian Dennis

Sounds like their LMS is hosting ("framing") the lesson differently, and code in that frame is blocking the print button. Honestly, I'm a bit surprised as normally right-click is blocked by code, not the Print button. I suppose their LMS could be settings things up for full screen "kiosk" mode so there's no Print button physically displayed. Any idea which LMS they are using?

Carol Mealy

Thank you...was not able to find a solution because it seems that it is an LMS issue not a Storyline issue. The site developer is deleting the certificate and having the learner access the certificate directly from their LMS.

I am curious as to why this certificate has become such an issue. I set up the print functionality as seen in the screenshots I included in the original post. These instructions were given to me from a Storyline training session I took 3 years ago. It seemed like a simple thing to do, and since it works in our LMS, I assumed that it would work in any LMS. Apparently not. Because I'm not a full-fledged IT person, I don't really understand the coding behind this functionality. But, I am including here feedback from the LMS team who is having the issue:

- Print preview did not work for me on IE
- Printing on the B&W printer worked
- Printing on the color printer did not (the certificate appears too big and half of it was missing)
- Printing as PDF did not work either (which would have been the way to save a copy).

 

Ashley Terwilliger

Hi Carol,

I can't speak to the different printers, as that sounds more like the way the printers are set up and you'd want to look at how they're set to print other HTML generated pages. 

As for the print preview, if you're trying to print from within the preview of Storyline that functionality will not work since it's pointing and linking to an external page. The same would be true of testing the published output locally vs. uploading it to your intended publish environment.