Print Results report doesn't display in IE

May 18, 2018

My struggles with IE continue.  I have a print results button feature in a brief survey.  

Tool: Articulate360

First attempt: I published for flash with html5 fallback.  Survey plays in IE.  Print results pulls open a blank IE browser page.  Survey plays in Chrome.  Print results displays the results.  

Second attempt: I published for html5 with flash fallback.  Survey plays in IE. Print results pulls open a blank IE browser page.  Survey plays in Chrome.  Print results displays the results.

As our company's standard remains IE 11, it must work there first.  Is there any tweak I can apply to the report.html to force it open in Chrome or is there something else I should try?

24 Replies
Alyssa Gomez

Hi Sandra!

Really sorry for the trouble you're running into. 

We were seeing an issue where the print results trigger generated a blank report when content is viewed on Internet Explorer 11, but we've since fixed that issue in a previous update of Storyline 360.

Are you on the latest update of Storyline 360? To check, click the Help tab, then click About Storyline. You should see 3.15.15581.0 in the bottom-right corner. 

Sandra Lowe

Hi Jeannette, yeah.  I am convinced at this point it's the way our IT infrastructure is built.  It's like they don't/won't recognize the LMS when they develop updates.  I am in limbo right now waiting to see if we will switch to a Chrome standard.  In the meantime, most of our machines (as you know) do have Chrome automatically installed so I have had to occasionally provide instructions for users to force things to open in Chrome.  That the entire IT dept now uses Macs adds a whole other dimension to our testing platforms.

Ashley Terwilliger-Pollard

Hi Sandra and Jeannette,

What are the IE versions you're both using? I've heard of users running into issues with an LMS set up where it forces IE11 to display in compatibility mode, which essentially forces IE11 to behave like IE7 or IE8. 

Let us know if you can pin that down! If you wanted to check into the compatibility mode piece, here's how to check and change your settings. 

Option 1: Change Your Compatibility View Settings

  • Click the gear icon in Internet Explorer (or click the Tools menu if it's visible), then choose Compatibility View settings.
  • If the website where your course is hosted is listed in Compatibility View, select it and click Remove.
  • Also, if you're using an intranet, such as SharePoint, to host your Rise course, temporarily uncheck Display intranet sites in Compatibility View.
  • Click Close, then launch your course again. If the page is still blank, try the following method.

Option 2: Use the Developer Tools to Switch Document Modes

  • Click the gear icon in Internet Explorer (or click the Tools menu if it's visible), then choose Developer Tools. They'll open across the bottom of your browser.
  • On the right side of the developer bar, you should see an icon that looks like a computer monitor and a smartphone with a number beside it. When you hover over the icon, a tooltip will say Document mode (with a number). Click the icon to display a list of Internet Explorer version numbers.
  • Select version 11, then launch your course again.
Sandra Lowe

Jeannette and I work for the same company albeit different locations.  We are on IE 11 and many of the settings are locked out for us to adjust.  Plus I we need to make these kinds of settings changes, then I assume anyone else trying to run the course would have to as well.  Our audiences are too large to make them manually make these settings changes.  I fear we will have to simply recommend Chrome when allowed or skip these features while we are still expected to work in IE.

Leslie McKerchie

Hi Stefan, 

Thanks for reaching out and letting us know what you are experiencing with your course.

I'm curious what version of Storyline 3 you are currently using? Update 5 included a fix related to the print results function, so I wanted to be sure you were on the latest version.

Hi Ray,

Thanks for keeping us up-to-date on your progress. You know where to find us if you need further assistance.

Crystal Horn

Hi there, Stefan.  Thanks for the detail!  We have documented an issue where printing results isn't working when you launch the output using the launch_story.exe of CD output.

The workaround for this issue is currently to use the story.html (or story_html5.html) file to launch the course.  We'll let you know if this behavior changes!

As for the learner's name prompt, pop open the trigger to print results, and you should find that option here:

Ray Darman

Here's what's going on.  IE11 defaults back to IE7 in developer tools for people with older computers.  I can manually set it up to IE11 and the screen will appear, but once I close developer tools it goes right back to IE7.  People with newer computers this isn't a problem since their processor can run IE11.  The average computer user would have no clue how to monkey around with developer tool settings.

It would seem to me that the Articulate software developers would create a patch that would identify the processor speed of the computer then adjust the print setting to display correctly on whatever version of IE that is currently running.  I'm guessing they just figured everyone is running IE11 which is not always the case.  This is why multiple people are having trouble with this.

Crystal Horn

Hi again!  I tested a Studio '13 presentation with Print Results enabled in IE 11, and then I used the developer tools to emulate IE 7.  I was able to see the Results tab open in the browser in both scenarios.  Can we confirm that it isn't a pop-up blocker issue, also?  Regardless, not to fear - we'll keep working on it!  

With your permission, I'd like to take a look at your project file to investigate what's happening. You can share it publicly here, or send it to me privately by uploading it here.  I'll delete it when I'm done troubleshooting. 

This discussion is closed. You can start a new discussion or contact Articulate Support.