Problem with text box on base layer disappearing before trigger on base layer has been activated

I'm currently working on a project where I've used a series of layers, states and triggers to get a text box to appear on the base layer by way of a fly in animation and for the text box to be visible unless and until the user has clicked on any one of a series of tabs (also on the base layer) at which point the text box simply flys out. I've experimented with "Show Until End" and "Show Always" but I don't seem to be having much luck getting the text box to be visible permanently unless and until the user clicks on any of the tabs.

When I tested this by previewing the entire project and then leaving it up on screen without clicking on any of the tabs the text box would always disappear sooner or later. 

Ideally, I'd like the person viewing the slide to be able to have a short break, come back to the slide and for the slide to look exactly as it did before they went away. In other words, 30 minutes may have elapsed but the slide would still look exactly as it did before with the tabs and the text box still visible on the base layer.

I've attached a copy of the .story file in the hope that someone will be able to help me. Am I doing something wrong here? Is there an easier way of doing this? Thank you.

1 Reply
Walt Hamilton

If the textbox has an exit animation, it will always begin that animation in time to complete it when the timeline ends, even if set to show until end, or show always.

If you want it to always be visible, either take off the exit animation, or pause the base timeline before it ends (assuming the slide advances by user action.)

Also note that while the SL community is in a state of flux between SL2 and SL 3(60), it helps to note which version you are using.