Problem with Storyline HTML5 display on iPhone

Hello all,

We are having a problem with Storyline HTML5 display on the iPhone. Even though my player is set NOT to show the title, the attached is what we are seeing.  It has a wide gray background and a white border with the file title on it, even though  the background, player and title text are set to be transparent.

The file size is 320 x 480.  Set to resize to fit the user's browser.

Please advise!

Thank you,

Ellen

9 Replies
Christine Hendrickson

Hi Ellen!

To properly view Storyline content on an iPhone, include HTML5 output when publishing, and launch the course in mobile Safari. There's more info here. Are those the steps you're following? Also, be sure Safari is not set to Private Browsing mode

If you check the information above and still have an issue with the title and background displaying, please submit a support case including your .story file, so our support team can assist you.

Ellen Brodsky

By playing with the story_html5.html file, and changing the Align setting to "left" I was able to get a little bit of improvement. But still cannot get rid of the gigantic white title bar at the top that is pushing off a lot of the content. (See attached.)

How can I get rid of (or considerably shrink) that top title bar? My content is only 280 x  420, so it should fit on the iPhone screen.

Please advise. As far as I'm concerned, this is NOT working properly on iPhone and I am quite shocked, as my understanding was that this product could display properly on the iPhone.

Thank you,

Ellen

Christine Hendrickson

Good morning Ellen,

I see that you were able to open a case and that Jayem has been working with you. I'm glad to hear that you were able to improve this a little, but please make sure you share this information with Jayem as well.

Please keep in mind that the mobile player is designed for the iPad. If you'd like to see support for a specific mobile device, please submit a feature request

Having said that, there may be a workaround you could try. I found a post by another Hero in this thread. She was having a similar issue, but in landscape display. They suggest removing the navigation and other elements and adding your own navigation buttons to allow the presentation to fit within the screen. Have a look at the thread and see if this might be an option for you.

Gonzalo Rosetti

Hi Christine & everyone,

I am getting the same kind of choppy results when I try to get a SL SCORM package run on Moodle on the iphone.

I have set 100%x100% window frame to host the SCORM package on Moodle.

However, it is perfectly seen when the SL SCORM package is seen o the iPad or  from outside Moodle.

Any ideas?

Ashley Terwilliger-Pollard

Hi Gonzalo,

Can you tell us more about the choppy results you're experiencing? Are you referring to sizing/position while on the iPhone or the playback? Also, this thread dates back to 2012, so it's also worth noting that we're now on Update 5 of Storyline, and over those updates there have been a number of HTML5 fixes and improvements detailed here.   Do you know what update of Storyline you're using? You can check by going to the Help tab -> About Articulate Storyline and you'll see your update number listed like below

Gonzalo Rosetti

Hi Ashley,

I am using SL latest update 5, and the SCORM package is hosted on Moodle 2.6

As mentioned in the following threads, miracle should have happened but it has not unfortunately when SL runs in a SCORM frame in Moodle 2.4 and above. It works perfectly when it runs as a standalone on a server, though!

Presentation size on iPad and iPhone

http://community.articulate.com/forums/t/14274.aspx?PageIndex=1

iOS7 and Storyline

http://community.articulate.com/forums/t/36393.aspx?PageIndex=2

I am getting today, using  the latest version of both SL and Moodle the same kind of results shown above (Posted Wednesday, November 14, 2012 at 7:11 AM)

As this post is quite old, I opened a new one: http://community.articulate.com/forums/t/48498.aspx

so we can follow the discussion there. I will also take this responde there too.

Thanks a lot!