Problem with Text Entry fields not recognizing the Enter key

I have a text entry field (I have tried both numeric and text entry) that is not working when published.   It works as intended in preview mode but once it's published, the Enter key no longer functions to show another layer.  I have removed the fill and line from the field. 

I am wondering if anyone can figure out why this isn't working.  A previous version of this slide worked correctly.  I'm using the most recent version of Storhyline 2.

53 Replies
Emily Ruby

Hello Edward!

I tested your file in a published version and the enter key did work as expected. Can you view this here and see if it is working for you?

Please makes sure you are testing your published output in its intended environment as viewing locally can have security restrictions from the computer, web browser, Flash Player, and network that'll cause various features of your content to fail.

Daniel Mitchell

Edward, did this issue get resolved for you?

The reason I ask, even though it looks resolved, is because I wonder if the staff tested the same way you tried to publish. I am having the exact same problem, but I have more detail about what's happening.

It appears that when I publish to LMS (probably the same if I publish to the Articulate Online service), the Enter key works fine, but when I publish to CD, it does not. This is a serious, serious problem with SL2 that did not exist in SL1, and the support staff couldn't figure it out, but forwarded the issue to Quality Assurance.

Kathy Miles

Hi Leslie,

The problem isn't even with a free form text entry, it is just for a standard text entry in a scene. The submit button makes the program take a longer and another button isn't an option as we want to reflect what they would actually do in the system they are being trained in (which is press enter). As everyone else has said, it works fine in preview just not once published. This seems to be a pretty big bug causing a lot of people stress and more work. I'm hoping the QA team can resolve it quickly.

Kathy

Sandra Lowe

Me too!  I am in panic mode right not because my "press enter to continue" is failing in my CD versions of a series of 14 courses.  It works perfectly in our LMS and in preview.  In CD publish, it's a no go.  With no obvious answer, I am having to republish and put the next button back on the screen so there's another option for users to advance.  I am hoping there is a solution to this as opposed to it just won't work in CD format. 

Crystal Horn

Hi Sandra.  I'm sorry this issue is causing you frustration.  You've definitely put in a lot of work for 14 courses.

I don't have anything new to report yet.  The QA staff are still investigating the "enter" key on the CD published version of the course, and the current workaround is to use a different key.  That being said, we will continue to advocate your needs!

Crystal Horn

Hey Paul.  We don't have a resolution for this issue yet.  I know that's probably frustrating to hear.  We are continuing to update our QA people on the overall impact this malfunction has on our customers, so I'm glad that you checked in to inquire and share.

The workaround right now is to use another key, if that's possible with your setup.

mohamed ismail

we are facing an issue in Articulate storyline 2 LO’s,  in this LO activity the user should type the answer for every question and  submit it

and then print it, the issue in the text entry when the user type 2 paragraphs or more in the print page will ignore the enter button so will appear like one paragraph without spacing  it looks so weird is there any solution for this.

thanks.

mohamed ismail

Hello Ashley, thanks for your reply no it's just happening with me on the print result page the text entry field is working fine i tried a lot of solution by using javascript or manipulate the variable itself and nothing is working and it's a most to report to lms as per client request.

Sent from my iPhone

Ashley Terwilliger

Hi Mohamed,

Thanks for those images. The variable is holding the text, and to report it to the LMS or the printing option, it strips out the formatting elements such as the line spacing. As for the Javascript you tried you may want to share more information on that here, as it could be something the community has expertise in and could weigh in with some ideas.