Publishing Engage Interactions in Storyline - Engage does not load

Hello,

I have a real problem with Engage Interactions in Storyline. When I publish the Storyline file, the engagements to not load. I get a blank slide. I actually have 2 files where this is happening.

My troubleshooting includes:

  1. deleting and re-importing the interactions using the methods for import in tutorials
  2. changing publish setting to turn off HTML5
  3. changing engage startup optoins in Storyline from in slide to window (and back again)

Are there settings in engage that have to be set for the interactions to run in Storyline?

I have a deadline to meet so this is an important issue now.

Thanks for any help you can provide.

40 Replies
Justin Wilcox

Hi David.

Engage interactions are published as web objects. If you are viewing the content offline that may be an issue due to browser security issues. If you want to view your published Articulate content online but don't have a web server, one quick way tis to sign up for a free Dropbox account:

http://dropbox.com

Then upload your published content to the Public folder in your Dropbox account as demonstrated in this video screencast:

https://player.vimeo.com/video/143914364

Or, publish directly to your Dropbox\Public folder as demonstrated in this video screencast:

https://player.vimeo.com/video/143914426

I would try testing that. If you still have difficulty, feel free to submit a case

David Quackenbush

Hi Justin,

No I haven't. Unfortunately our process does not allow any elements to be added to the LMS until they have been reviewed and approved. I've been asking to have a 'test' section added to the LMS to use it for the review process, but no luck yet.

Even so, shouldn't I still be able to publish the Storyline file in LMS format and view it and see the imported Engage Interactions?

I wish that I could just build the interactions in Storyline, but they are being created by SMEs that only have Engage.

BTW I have created a case for support and uploaded the file in question.

Thanks for you feed back too. I love the drop box idea and will probably be using that for my review process going forward. 

So I tried publishing the Storyline for WEB, but still have the same problem, the Enagements don't start up.

Peter Anderson

Hey David!

Looks like Cleo has taken your case, will check out your files, and contact you with an update ASAP.

In the meantime, just wanted to add that another great way to test your content, is to use Articulate Tempshare. In circimstances where content won't function properly when viewed locally, it's an invaluable resource. But keep in mind, anything you upload to Tempshare will be automatically removed after 10 days. 

Jodi Delfosse

Has there been any resolution to this issue, which I also found in an August post, but again with no real resolution posted.  

None of my imported interactions are working when published, although they are clearly "there" and appear to have proper settings, when Previewed in Storyline. 

I tried the suggestion made in August (publish to LMS, uncheck HTML 5) -- no luck.

I tried inserting the published interaction as a Web Object  as suggested in a post earlier this month.  I  got further but it still is not working -- the interaction frame loads, but then it just processes.  

Thanks for any assistance you can provide.

Peter Anderson

Hi Jodi, welcome to Heroes!

Sorry you're running into difficulty with this. The most common reason for Engage interactions not showing up, is because the course has not been uploaded to its intended environment. You mentioned you published your course - did you publish for web, LMS, Articulate Online? And after publishing, did you upload and test the project in its intended environment (web server, LMS, AO)? If you try to test your course locally after publishing, you may run into security restrictions preventing certain features from behaving correctly. 

If you'd like to attach your .story file here, I'd be happy to give it a test myself to see if there may be something else going on.

Let us know...

Thanks, and welcome again!

Jodi Delfosse

Thanks, I just got it to work by A) importing the Engage separately (not as part of my PPT package), and B) publishing to CD. Interestingly, it still doesn't work when I view the .html file in Chrome - only the .exe displays the engage interaction correctly.  I had been publishing to web and LMS, which normally work ok for me in terms of viewing Studio output, but I guess not for Storyline.    I had tried various things yesterday before I wrote, but not this particular combination.

Jodi

Christine Hendrickson

Hi Jodi. Welcome to E-Learning Heroes,

You mentioned that you're publishing for the LMS, but are you uploading the content?

First, please make sure you're testing the content in the environment for which it's intended, if you preview or view the content locally, the Engage Interactions may not play properly. If you're publishing for the LMS, you'll want to upload it to the LMS to test it. If you view published Storyline content on your local hard drive, you'll encounter security restrictions from the computer, web browser, Flash Player, and network that'll cause various features of your content to fail.To properly test your published content and share it with others, upload it to the environment for which it was published. Please review this article for details.

If you continue to have problems viewing the interactions after uploading the content to your LMS, please let us know.
Thanks!
Christine
Tessa Waite

Hi,

I am having a similar problem and none of your suggestions seem to be working. I have a Storyline project which I have imported 1 slide which is an Engage slide. Whenever I publish my project the slide is blank, even when I publish in a Dropbox public file and share it with another. I am publishing to the Web. The Engage slide includes a video (.flv file) but this works in the Engage preview...could this be the problem?

How can I resolve this issue?

Thanks

Christine Hendrickson

Hi Tessa,

Are you able to share the .INTR file here for the Engage interaction? I've heard of some issues with Dropbox recently, also interactions won't play in preview mode for Storyline and won't display properly if you view the published content locally. I'd be happy to try to insert the interaction into a Storyline course and see if it works when uploaded to our servers. You're also welcome to send the file to us privately, if you don't want to post the file on the forums.

Thanks!

Christine Hendrickson

Thanks very much Tessa. I was able to find the case and I took a look at the course.

I'm not experiencing the same problem, however. I uploaded the course for testing and I'm able to navigate to and play the interaction (for Burns, Minor injuries, etc.). It does look like this may be an issue with the FTP or hosting on Dropbox.

I'm leaving the case open, so our support staff can test this a little further. In the meantime, I can send you a private message with a link to my published version, if you'd like to take a look. Just let me know!

Thanks again, Tessa.

Christine

Christine Hendrickson

Hi Jesse,

This issue seems to come up a lot now. I noticed more issues popping up after Dropbox changed the way their public folder functions. The problem is that Dropbox is not truly a host for courses. It's a storage service, which works well I must say, but it's not the best place for hosting your content if you plan on distributing it to others.

Do you have access to another host, maybe a web server or LMS? 

Mike Gault

Hello,

I am experiencing the same issue (Engage not running within Storyline after publishing).  I did web publishing and then uploaded files to ftp.  When I try to run the course on my web page I get a blank white screen where my engage interaction is supposed to appear.  The storyline portion seems to be working OK, just can't get the engage interaction to run.  Any ideas?

Thanks,

Mike

Fabrizio Imbriano

Hi there,

I have recently imported an old course into Storyline which was done in Articulate Studio, ensuring to import all the engage interactions individually, but as with the above comments, when I publish the course, the interactions don't show. This is despite the fact that when I open it from the "Launch story" (Storyline icon) it appears to be in working order.

This is a high priority for an external client, so they need to be able to view the course before signing off on it, and as they don't have any Articulate software on their computer they will not be able to view it via the "Launch" icon. 

Any ideas would be greatly appreciated!

Many thanks,

Fabrizio Imbriano

Ashley Terwilliger

Hi Fabrizio,

So you've followed the steps here to import the Engage files?  You'll also see the error message detailed here if you've had difficulty importing them from your Presenter files and troubleshooting steps to import them correctly.    

Also, since Engage files are included as web objects, you'll need to use the "Launch_story.exe" file when publishing for CD as described here.  You'll need to share the entire published output folder with your reviewers. Also, you may want to look at any of the web publishing options here to host your content for review.