Quiz not registering as completed on 2nd attempt - LMS

Hi,

We have created a quiz using question banks and it has been set up to allow the user 2 attempts. We currently have a problem where our LMS fails to register the second quiz attempt. This means that when the user fails on the first attempt but passes on the second, it registers them as having failed the quiz.

We have raised this with our LMS providers and they have told us it is to do with the way that our story is set up and that it is only registering the score of the first attempt. They suggested we add a trigger that clears the score of the first attempt when the user retakes the quiz but I am unsure how to create this in storyline.

Is there a trigger I can set up to do this?

Many thanks,

Sophie

11 Replies
Justin Grenier

Good Morning, Sophie.

Most learning management systems (LMSs) consider a course to be in review mode when attempting it again after the completion requirement has been met. When in review mode, new data is not reported to the LMS. This prevents learners from accidentally changing their course status from complete back to incomplete.

If you'd like to change this default behavior, it's best to change it in the LMS. However, if you'd prefer to modify the published Articulate output instead, follow the instructions within this article.

Good luck!

Justin Grenier

Good Morning, Sophie.

Double-clicking the Configuration.js file will not open the file in Notepad.  You will need to either...:

  • ...right-click the Configuration.js file and click Open with -> Notepad.

...or...

  • Open Notepad first, and browse directly to the folder location where the Configuration.js file is located.

If you continue to have trouble, I would recommend enlisting the assistance of a colleague with some development experience to help you make this change.

Good luck with your project!

Michaella Roess

Hi Justin,

Thank you, the second option seemed to work, but unfortunately the module still isn't working properly.

When you said earlier about changing this in the LMS, can you tell me how I would go about this? Is this something I can do or would I need to contact the providers of our system?

Many thanks,

Sophie

Michaella Roess

Hi again,

Our LMS provider has said that it is something to do with the story rather than something they can sort out on the LMS system.

Is there anything else we can do to solve this problem? We are due to launch it to our company soon and have no idea what the problem is. We have two similar assessment modules and one seems to work perfectly while the other has this problem with the only the first attempt registering.

Many thanks,

Sophie