Quiz Scoring Issues

This week I've been converting an old Captivate course to Storyline but it appears that I've hit a brick wall.

I have several older Captivate courses that restrict the user to 2 attempts before locking them out. The user is reported as "Complete" if they pass the test on either attempt and "Incomplete" if they fail both attempts.

I've rebuilt this in Storyline by counting the number of times the user clicks the Retry Quiz button and turning it off when the user completes two attempts. However, when the Storyline version is closed (after the 2nd attempt) the user is immediately reported as "Complete" - regardless of the user's test status.

Is there something else I need to do in Storyline for this type of testing?

7 Replies
Christie Pollick

Hi, William -- Thanks so much for reaching out here! My apologies if I am not clear on what you are asking, but I just wanted to confirm that you have followed the steps outlined here for Publishing for LMS, and you may also want to see here for more info on How to Report Completion status. This post also has some good information on completion status, as well. 

William Wallace

No worries, sorry if I wasn't clear before. I will try to restate my issue with a bold on the sticking point.

For this course the user can take the quiz 2 times then the course is locked and their grade cannot be changed.

In the original module (Captivate) if the user passes the quiz on the 1st or 2nd attempt they are recorded as "Complete". If they fail both attempts they are listed as "Incomplete" and the course is locked.  <-- This is the correct behavior.

In the new module (Storyline) if the user passes the quiz on the 1st or 2nd attempt they are recorded as "Complete". If they fail both attempts they are listed as "Complete" and the course is locked. <-- This is not correct.

Obviously they should not be listed as Complete if they failed both attempts.

William Wallace

Thanks for getting back to me so quickly after I uploaded the file.

Since it appears that the issue is the way my LMS reads the results of the SCORM module, I thought I would try packaging the program as AICC. Once I converted to AICC the LMS displayed the correct results.

So just as an FYI for others that might be in a similar situation. The LMS was CourseMill and the fix was to switch from packaging as Scorm 1.2 to packaging as AICC.