Resuming a course does not work

Hello everybody.

 

Currently we're experiencing a problem with the resume functionality of our courses. When we launch a course in our LMS that has previously been closed, it doesn't (prompt) te resume the course when we launch it again.

These courses are built in SL2. Whether we check the player options 'always resume' or, 'prompt to resume'. The courses don't resume when they're launch from the LMS. We're publisching our courses as Scorm 1.2. 

We've had the faint hope upgrading a SL2 built course in SL360, would fix this problem. But it doesn't. We tried publishing the course in 360 as fully HTML5.

 

Is anyone experiencing the same problems, or does someone have a solution.

 

Regards,

 

MickyS

9 Replies
Alyssa Gomez

Hi there Micky!

Have you done any testing in SCORM Cloud yet?  If so, are you getting the same results? We generally compare the behavior in SCORM Cloud to your LMS experience to try to parse out file issues versus LMS issues.  We are happy to help you with that testing if you'd like to share your file!
Scott Wiley

You might also check to see if bookmarking works correctly "before" the course is marked complete.

We ran into an issue where instead of using the built-in methods of marking completion (score or slide count) the developer used JavaScript to set completion. I've used the JavaScript method before with no problems, so it is not being blamed as the culprit. But in this scenario, for example if you launched the course and closed it before the JavaScript did its thing, bookmarking worked fine. Once it was completed, it did not prompt to resume and instead forced the learner back to the beginning.

It may have been a combination of the publish settings (in this case published to SCORM 2004, 4th Edition) and the JavaScript that caused the issue.

I ended up removing the script trigger and using built-in slide count methods instead, which fixed the problem in this case.

Good luck.

Ashley Terwilliger

Hi Ravi,

I'm not sure what the error was, but  you could always use the "contact me" button on a ELH users' profile to reach out to them directly! 

Also, feel free to use the steps here to test at SCORM Cloud. You can compare that to your testing in the LMS and even use that information to pass along to your LMS admins.

Micky Surisiay
Ravi Sharma

Hello Micky,

Great that you were able to resolve the issue. We are also facing the same issue. can you please help with the solution?

 

Hey Ravi,

 

I haven't got the full details, as our it departement solved the issue. If I understood them correctly, I was testing the output in an outdated LMS enviroment.

 

Good luck!