SCORM 1.2 - "Completed/Incomplete" option not working. Only "Passed/Incomplete" is.

Hello,

I've got my Storyline2 course set to report in SCORM 1.2, and to report as "Completed/Incomplete", yet the course always reports as "Passed/Incomplete".  Tracking is set up to track using number of slides viewed.

Has anybody seen this problem before? What can we do to have it work correctly? Our client is requesting the LMS Reporting be set to "Completed/Incomplete", please help! We have a very tight deadline that we have to meet.

Thank you for your help in advance.
Omar G.

7 Replies
Emily Ruby

Hi Omar,

If you choose a reporting status of Completed/Incomplete or Completed/Failed when you publish, you may find that your learning management system (LMS) shows a status of Passed rather than Completed.

This is a known issue. It'll be fixed in a forthcoming software update for Articulate Storyline. In the meantime, you can avoid this behavior by adjusting the SCORMFunctions.js file in your published output. Here's how:

  1. Go to the folder that contains your published output and open the lms folder.
  2. Open the SCORMFunctions.js file in a text editor, such as Notepad.
  3. Locate the following line of code:

    var SCORM_PASSED = "passed";

    And change it to:

    var SCORM_PASSED = "completed";
  4. Save and close the SCORMFunctions.js file.
  5. Zip the modified published output and upload it to your LMS for testing.
Michael Law

I've been manually updating the SCORMFUNCTIONS.js file since I started using Storyline 2 about 2.5 years ago.  Every time I publish a course, I need to use this method.

On Storyline 360, I am still getting the same results when publishing and viewing the reporting status.  I am publishing to SCORM 2004 - 4th Edition and selecting the "complete/incomplete" reporting status.   

I am doing everything possible on my end such as consulting with our LMS Administrator to determine if anything can be done internally.  I will also be submitting a ticket to Articulate to highlight the importance of this option working properly.