Seek Bar doesnot run when you replay the slide

There is an issue with the seek bar, In a tab interactivity, when I click on base layer button, a layer will be shown, there is some animation in it, when timeline ends, When I click on the replay button, the animation will play but the seek bar does not show any progress. And the play button will be active. when I click again on play the seek bar runs. 

Basically when you replay the animation the seek bar doesn't run, though the play button is active. Can anyone provide a solution for this.

30 Replies
Christie Pollick

Hi, Archana -- Thanks for reaching out! As Charles suggested, please see this information on Adjusting Slide Properties, particularly the section below and let us know if you still need more help! 

Determining How Slides Behave When Revisited

Storyline lets you decide how objects behave when learners revisit the same slide later. Choose from the following:

Resume saved state: Use this option if you want the slide to always remember its previous state. In other words, this option lets learners pick up where they left off when they leave the slide and come back to it later.

Reset to initial state: Use this option if you want the slide to always reset to its initial state when learners return to it. It'll restart from the beginning of its timeline, and interactive objects will return to their initial states.

Automatically decide: This is the default option. It means Storyline will decide whether to resume or reset the slide based on the objects it contains. Here's the logic: If the slide has only simple objects and/or audio but no interactivity, Storyline resets the slide to the beginning of its timeline. However, if the slide contains interactive elements, such as buttons or other objects that have a visited/selected state, Storyline resumes the slide where it left off previously.

Ali Goulet

Hi Michael- Thanks for popping in here and sharing your experience. Are you seeing this happen when previewing in Storyline 2 or just when viewing the published output? Would you mind sharing your .story file here so I can take a look? You can add it as an attachment right to a comment in this thread. Thanks!

michael wylegly

There's nothing to share, it's a general issue that we're seeing on all of our courses. If you have a slide with slide layers, you let that slide complete, then hit the replay button, the seekbar will restart that slide layer, but it will not let you use the seekbar the way the seekbar was intended (the pause and play specifically). 

Ali Goulet

Hi Michael- Thanks for the additional details here. I was able to reproduce what you're describing and this is an issue that our Quality Assurance team is aware of and investigating. I don't have any updates at this time but I've added this thread to the report. Since you're subscribed to this thread, you'll receive notifications of updates when applicable. 

Paula Obrien

I've run into the same issue. My slide has audio on the base layer and interactivity. I've created a trigger to pause the audio when the timeline starts. When the user clicks Play on the media player controls, the audio and seek bar start. At the end of the audio clip, pressing Replay on the media controls does nothing. Clicking Play again also does nothing. Is there another trigger I need to add so that the replay button will work? Thanks!

Paula Obrien

Oops! Never mind. I changed my trigger to pause the TIMELINE (instead of pause MEDIA > audio file 1), and chose to Reset To Initial State. Now the functionality is working as expected. The slide opens. The user decides when to play audio. And, the replay button resets the seekbar and audio to the starting state where the user can play it again.

cynthia Giyani

Good day,

 

I have come across this similar issue. what happens is I have an interactive video that pauses once an icon appears, this icon allows the learner to jump to a question slide that is a lightbox. once the question has been answered, the learner goes back to the slide with the video.  The issue here is that the video continues to play (the timeline resumes with a trigger) but the seek bar does not work.

Please assist urgently 

Jeppe Bylov

Hi Leslie

Using StoryLine2  I'm having the same problem as Cynthia Kuni. Video is paused by cuepoint, user clicks button to open lightbox containing quiz (of type Numeric Entry), user interacts with quiz, user closes lightbox -> seekbar is no longer active = not clickable and not updating progression

Is this a known issue - with a known solution?

My project file is close to 2 GBs so I'm afraid upload is not possible.  

 

regards,

Jeppe

Alyssa Gomez

Thanks for sharing this slide with me, Cynthia!

I can see you're using the "When Revisiting: Automatically Decide" setting in Slide Properties. Since your slide has interactive elements, Storyline won't rewind the slide with the Automatically Decide setting. 

Try switching to the Reset to Initial State setting instead. This option will always force the slide to rewind.

Let me know if that helps!

cynthia Giyani

Hi Alyssa,

thanks for the reply.  I have since applied your suggestion but unfortunately this has not changes anything. when i click on the same option twice, the seekbar does not play the second time around.  Please find attached amended story and published file.

Alyssa Gomez

Thanks for clarifying that, Cynthia. You're right--when you revisit a slide layer, the seekbar will not play the second time around.

Our team is looking into this bug in Storyline 2, and we’ll continue to keep an eye on it to evaluate how many customers are impacted and what impact it has on courses. The number of customers and depth of impact are two of the elements that help us prioritize bugs and fixes.  

Here's some more detail about how we tackle bugs.  I'm really sorry that I can't say if this issue will be fixed, but you're in the right place to stay updated on this bug's progress.