SL2 runs very slow

Ever since I have upgraded to SL2, it runs very slow on my laptop. I am not talking about the published output. I am talking about working on the .story file itself. SL2 takes atleast 5 seconds to respond to every click .

My laptop runs everything else super fast. In fact, I tested with only SL2 running after a reboot. The CPU and Memory meters are fairly low too when SL2 runs. Yet, SL2 is very slow. I even ran SL1 and SL2 in prallel, and SL1 runs fine, but SL2 crawls.

Anyone else face this issue?

9 Replies
Soren J Birch

Im facing the issue that Storyline 2 is SLOWER than Storyline 1, but I cannot recognize the exeprience you have in that level of slowness. Work is more sluggish but it isn't much and it doesn't stop me working, but SL2 is definitely no race horse. If your laptop is at the edge of the specs for SL1, I think SL2 is demanding more and somewhat slower to work with. 

 

What windows version are you running it on?

Ron San

Windows 7, 64 bit OS,  4Gb ram, quad core i5 processor, 1 Tb hard drive (300+gb free space)

For me its getting pretty serious now...to the point that I may have to move back to SL1 for this reason alone.

I hope there is some setting I can change to improve performance.

Anyone aware of such a setting/workaround?

Ashley Terwilliger

Hi Ron,

I'm sorry to hear about the issues you've run into with SL2 being slower. I do see that our team has looked into some issues with overall slow performance and SL2 does involve more elements than SL1 so takes up more space, memory, etc. 

You'll see a reminder about the system requirements here, and it sounds like you're well within that set up. Have you tried a repair to resolve any general odd behavior? 

Bruce-Alan Barnard

Wow ... I am having that issue now with an i7 clocked at 2Ghz Windows 10 system with 8GB ram. I click and wait three seconds. I disconnected from the internet and have no other processes tying up resources. I'm in a crunch to get this project out to a client and now I'm pulling my hair out with the sluggish response. I moved the file to the desktop which had no impact. I am in airplane mode and I am not connected to the internet so there is literally nothing else going on. I have the latest update installed.


Did anyone ever discover the cause and a fix for this?  I'm going to miss my deadline if I can't get this sorted out pretty darn soon.

Alyssa Gomez

Hi Bruce,

Sorry to hear you're experiencing these issues! I know that is frustrating. If it's just one file that's running slow, you may want to try to import into a new project. If you're having issues with Storyline in general, then you may want to try this troubleshooting that Ashley mentioned above.

If you have already tried these suggestions and are still experiencing this behavior, I would recommend connecting with our Support Engineers here. I know you're in a crunch, so be assured that they’re accessible 24/7. If you decide to open a case, let me know the case number I can follow along, as well.

Alyssa Gomez

Hi Maja,

Although resources and glossaries are configured in the player, they aren't stored in the player. As a result, you can't share resources and glossaries with other projects or other developers by using the same player.

To share resources and glossaries, create a Storyline template

Quick tip: You'll want to start a new story from the template for the resources and glossary to populate the player. If you import the template into an existing story, the resources and glossary won't populate the player.