Storyline 2 -custom layer for invalid answer

If users click 'submit' but did not answer the question, I wish to show a custom invalid answer layers, that tells users to please answer the question before they submit. I've managed to do that, but Storyline also shows the in-built invalid answer message on top of my custom layer. See image 1 screen shot.

How can I remove the in-built message? I wish to keep my custom layer, but remove the in-built message.

I've created states and conditions. But still not working well.

See video: https://www.screencast.com/t/8thXsVsIJ6f8

Attached the Storyline file.

12 Replies
Wesley Adams

Yep I'm really stumped on this one. I used the normal custom Invalid Layer steps found here:

https://vimeo.com/131808190

Had to strip down my series of questions but I basically get 2 issues out of 3 questions:

Question 1 - Is a Pick One activity where selecting the Submit button with no answers selected shows both my custom Invalid Layer AND the default Invalid layer on top of each other.

Question 2 - Is a Pick One activity where selecting the Submit button with no answers selected performs no action at all.

Question 3 - Is a Pick One activity where selecting the Submit button with no answers selected correctly shows only the custom Invalid layer.

So it does work sometime as seen in Question 3. I just have no idea why it doesn't anymore in 1 and 2.

Wesley Adams

Alrighty, got some more eyes on this on my end. Looks like I've been working on this too long. These were easy fixes.

Question 1 had a condition on the reveal Invalid Answers layer that was different from the others. So I fixed that and now works with no default Invalid Layer popup.

Question 2 I had the invalid Layer set with a trigger to hide the layer when timeline starts instead of timeline ends. So that fixed that too. 

Back to your regularly scheduled programming.