Storyline 360 file freezing during preview and publish

I have a course with a question bank. Half way through the question bank (a different question slide each time) the course freezes. The cursor turns into a spinning wheel and you can't advance to the next question, or results.

- I am working locally, from my Desktop.

- I have tried importing into a new file, did not work.

- I had a co-worker try it on their machine, same error.

- I have tried uninstalling and re-installing SL, did not work. 

- I have tried testing in SCORM cloud and receive the same error. 

I've included a screenshot of the "Freeze error." Thank you.

 

5 Replies
Alyssa Gomez

Hi Nicole,

It sounds like you've already done quite a bit of troubleshooting on your own, so I'm glad you reached out here! My hunch is that there's something corrupt on one of your slides--no worries, our team can help you find it!

Simply attach your unpublished file to this form, and we'll take a closer look. 🙂

Crystal Horn

Hi Cindy!  We didn't hear back from Nicole yet, but here's what I would consider:

Will that slide preview on its own?

Does temporarily removing that slide (I like to use cut and undo) allow preview and publish to function?

If so, I would dig further by removing elements from the slide, starting with layers.  I cut them, preview, and if it still doesn't work, use the undo function and cut something else.  Sometimes, one broken piece, like a text box, will cause a whole course to stop from previewing or publishing.  Deleting and rebuilding the piece will often fix it.

We're happy to help!  Share your file here and we can have a look.

Nicole Wachnin

Hi Cindy,

Try deleting those slides and re-creating them. I can't remember if I deleted the slides in question, or if I just copied everything into a new story file. Either way, It seems that Storyline has an issue with files becoming corrupt for no reason. When all else fails.. try a new file. 

Cindy Daoust

This is what I found. First, some basics about the course.

  • I am working locally
  • The course has been upgraded from SL2 to SL360 - the question bank worked in SL2
  • The course contains a drag-and-drop interaction within a question bank
  • The questions in the question bank are drawn randomly

I tried rebuilding the course and importing the question bank slides. Here's what happened:

  • If I imported every slide except the drag-and-drop slides, the question bank worked.
  • If I imported a drag-and-drop of any type, the question bank would hang up on the final question, whatever that question was.
  • If the setting was changed so questions weren't drawn randomly, the course still hung up on the final question. (Spinning wheel after the last question and before the Results slide.)
  • If I imported a drag-and-drop interaction into the question bank and DELETED it, the question bank would still hang up on the final question even though there were now no drag-and-drop interactions in the question bank.

I ended up getting rid of the drag-and-drop interaction in the question bank and substituted a different kind of question.

Sorry, but I no longer have the original file.