Storyline 360 Not Publishing SCORM with Video Properly

Hello,

I have read all the posts I can find describing similar issues and am not able to find a solution to this so far.

I have multiple SCORM files that I've been attempting to publish using Storyline. The projects contain a single slide with an MP4 and caption file inserted. They are then published to SCORM with the following settings:

HTML5 Only

Customized Player

Custom Optimization (6 quality, 56kbps, 100% image quality)

When published and saved as a .ZIP file, the SCORM package is only around 800 KB. Whereas we typically get a size of around 3000-5000 KB for a course this length. Looking inside the SCORM package, in the story_content folder, there is a video javascript file, but no MP4 file.

The original video files are around 80,000-200,000 KB in size, all are properly exported as MP4s. When I test the course out using the preview within Storyline, the video plays properly. When I launch the course after publishing, or upload the SCORM to our LMS, the video does not play. It's just a black screen. 

We have never had this issue until last week and we've published hundreds of courses following the exact same procedure.

I've tried some other things including: removing spaces from the MP4 filename, republishing the content from scratch with a new storyline project, running storyline as administrator, and reinstalling storyline all together.

To make this issue even more strange, my colleague is able to publish the files with the same assets and storyline settings with no issue on her computer. Also- after multiple attempts at publishing the same SCORM package without even changing settings, I have been able to publish one or two of the courses properly- however there doesn't seem to be rhyme or reason as to why.

This is a pretty serious issue for us right now as we need to publish new content on a daily basis. Can anyone out there help?

5 Replies
Katie Riggio

Welcome to the community,¬†Brittany ūüĆü Sorry¬†you're seeing a¬†black screen instead when uploading the¬†output to¬†your LMS¬†‚Äď have no fear as we're here to¬†lend a hand!

I'm curious if the black screen appears¬†in another LMS like¬†SCORM Cloud¬†‚Ästthe industry-standard tool for testing SCORM output. I'm also curious to know if the issue happens on a particular browser, or on¬†several types?

Lastly, I saw you submitted a case to our Support Team¬†‚Äď fine choice! Mind sending us your .story file so we can run some tests in several environments? Here's the unique, direct upload link which will route back to your case¬†‚Ästwe'll be standing by!

Trinity Ryan

Was there any update on this issue, or resolution? I am finding that this is happening to me too, and the best explanation is that Storyline 360 is failing to publish some/all of the videos which are embedded in my file. It happens randomly - that is, sometimes I can publish a file to LMS and all the videos are included, while sometimes they are not. I would love to know if there is a fix to this bug?

Katie Riggio

Hi there, Trinity. So sorry to hear you've come across this problem, and smart move to also open a case with our Support Team!

While I don't have any insight to share from Brittany's case, I see that you and Anna isolated the issue to a long file name length. Glad to hear that shortening the name helped!

Pro-tips for those following along:

  • Be sure the file paths to your projects and published output are well under the 260-character limit imposed by Windows. (The publishing process adds characters to the file path you selected. If it exceeds 260 characters, your published output will be incomplete.)
  • Avoid using special characters, accents, or symbols in your file paths and file names. Learn more about naming conventions in¬†this Microsoft article.

Please don't hesitate to reach out here, too, if you have any more questions!

Michael Heskey

Hi there! 

Pretty luck to have run across this article before spending more than I already have troubleshooting this on my own. I'm having the same issue as Raymond above. Has there been any progress in determining what the root cause of the problem is in the time since? 

I have several videos of varying sizes all in MP4 containers that are not making it out of Storyline and into the generated ZIP file for upload to our LMS. 

Leslie McKerchie

Hello Michael and welcome to E-Learning Heroes ūüėä

Thanks for reaching out and sharing that you are running into an issue similar to the initial issue shared here.

I was able to take a look at the support case where they worked directly with our team and it looks like we were unable to replicate the issue.

The recommendation shared:

  1. Make sure your work files are on your local drive.
  2. If you are already working from your local drive and Storyline 360 is still not working properly, a simple repair usually fixes the problem. 

We'd be happy to take a look at your files as well. With your permission, I'd like you to share your project file with our support engineers to investigate what's happening. You can share it privately by uploading it here. It will be deleted when troubleshooting is complete.