Storyline 360: Video will not play after publishing course - works fine in preview

I'm working on a course that has a video inserted on the second slide (after a intro/title slide). Everything is set to play automatically when the timeline starts. It works perfectly when I preview the course. After publishing to Articulate Review, that first video (there are several other videos later in the course) does not start playing unless the user (including me) clicks anywhere on the intro/title slide BEFORE the video slide starts. The timeline runs as it should - only the video doesn't start. If you click on the video it will start playing but it is no longer synchronized with the timeline. 

I've tried setting the video to play automatically. I've tried setting it to when triggered and adding a trigger to start playing when the timeline starts. Same problem. I even hid the video and reinserted another copy of it. Same problem.

Anyone else have a similar issue? Suggestions?

13 Replies
Ashley Terwilliger

Thanks, Patrick for that link. I was able to see what you're describing and it was only happening for me in Chrome (I also tested Edge and the video started there and stayed in sync even if I clicked on the video itself). 

Could you also share your .story file so I can take a look at how this is set up and do some more testing? If you need to share privately you can upload it to me here.

Chelsie Colvin

Patrick,

A colleague of mine experienced a similar issue to what you're describing. We were able to duplicate the issue in SCORM Cloud as well as in our LMS in both Google Chrome and Internet Explorer. The workaround we used (which we found via an old discussion thread on this board that I can't seem to locate at the moment) was to move everything in the timeline by 1 (one) second. So rather than starting at 0:00, the video was configured to start automatically at 0:01. This resolved the issue in both Chrome and IE. Best wishes,

Chelsie

Alyssa Gomez

Hi Nicole! 

Do you have audio or video on the first slide of your course? If so, are you seeing that the media doesn't play automatically in Chrome? 

Chrome recently changed their autoplay policy, and that policy affects courses that have audio or video on the first slide.

The good news is, we added support for Google’s new audio policy in a recent update of Storyline 2, but you mentioned you're still having the issue, even on the latest Storyline 2 update. 

The workaround Ashley shared with Patrick was to add a slide to the beginning of the course with a "get started" button. This button will ensure learners click on the slide area, and then the media should play automatically on the next slide.

If those tips don't solve the problem, share your file with us here! We'll be happy to have a look. 

Ashley Terwilliger

Hi all,

Thanks for your patience while our team investigated this issue. We've determined that videos not autoplaying on any slide without a previous user interaction is the expected behavior in Chrome and Safari based on their changes to media autoplay policies. 

This article is updated to reflect that and some ideas shared there to work around this browser limitation.

Szymon Wrzeszcz

I had today encoding issue with video after publish. I was checked folder story_content and I was wonder why I haven't got any video in location. After 2 hours I was turn off antyvirus and problem gone. Was some issues with encoding and saving video/audio files. Right now I can publish courses with all content.

Best,

Simon