Storyline Crashes Every Time I Open the Video Editor

I have a course that requires video, and I would like to edit it using Articulate's built-in video editor for the sake of convenience. However, every time I open the video editor after my initial edit (I successfully trimmed and cropped it once), Articulate freezes and becomes unresponsive to the point that I have to kill the process using Task Manager.

Any ideas for what could be causing this? I can edit using different software, but that would be a pain considering there's an editor built in to Storyline.

22 Replies
Joseph Flanagan

I thought I would respond here. I'm having much the same problem. I used the video editor to crop a video, and after that I can't import a video on any presentation (This is Storyline 1). It happened a few minutes ago before this time, and I had to restart Windows to get it to work. It only lasted a few minutes before it happened again. (Ironically, I tried to send an error report, which crashed the system as well). (and then about a hundred error report boxes opened up). 

Christos M.

Hello,

I am getting the same issue. The moment I right-click on video and select "Edit video", storyline freezes. In fact, it cannot even be killed via Task Manager and the PC requires a restart.

I have followed the instructions to perform a repair, but this has not helped.

I admit I am a bit surprised this has not been fixed after two years.

Thank you for your input.

Alyssa Gomez

Hi Christos! That's definitely not ideal, so let's see if we can narrow down why this is happening:

Simon Bratt

Hello,

I, too, am getting the exact same issue. The moment I select the recorded screen cast and click on "Edit video", Storyline 2 freezes. It cannot be killed via Task Manager and the PC requires a restart.

To answer the above questions:

I re-installed Storyline today so I must have the latest version.

I have checked that all the requirements are being met.

The file is saved on my desktop, as I now always work off my C: drive and then save across to a network drive when complete.

It's massively frustrating!

Ashley Terwilliger

Hi Simon,

I'm sorry to hear that you've run into this issue too, and that it's causing so much frustration. Did you reinstall Storyline from the install file already on your computer or did you grab the new install files here? 

Does this happen for every file you're attempting to edit the screencasts in? Or just this one file? Have you already tried importing into a new file? 

I'd want to have you work with our Support Engineers if you're seeing it consistently so then we can dig a bit deeper into what's happening on your computer. You can reach them here or I'm happy to get the case started for you!  Just let me know. 

Simon Bratt

Hi Ashley,

Thanks for the reply.

I should have said that the re-install was actually a re-use of the licence on a brand new machine I'd just been given. So, I downloaded Storyline 2 direct from the website for the first time.

It now happens in two existing files on the desktop, and also when I copy a single screencast into a new file, save it to the desktop, and then try and edit.

I shall raise a case with the Support team, as it's really frustrating and almost making Storyline redundant for my needs.

Thanks.

 

Ashley Terwilliger

Hi Simon,

I see you're working with Eloisa and she provided you some directions on how to gather system logs and working with your IT team to look at disabling anti-virus for the installation to complete. We have some steps documented for that here and I didn't notice that Eloisa sent those so I wanted to share here. 

Linda Jordan

I have been having the same issue for months. I've tried all the repairs, uninstall and reinstall the latest Storyline, etc. It is so frustrating. I can record a screen and play it back on the slide just fine, but the moment I select VIDEO EDIT, Storyline completely freezes. I can't even end task to close it. I could go on and open other programs and work, but Storyline will continue to stay completely frozen unless I log off of my windows account. I am operating from the C drive. I am an ADMIN on my pc.

I hope you can find a fix for this. It is seriously impacting my work!

Thank you.

Crystal Horn

Hey there Linda.  That sounds really frustrating.  It sounds like you've done everything right in terms of troubleshooting, so thanks for sharing those details here.  Was this working for you at one point, or has it always crashed when trying to edit the video?  

Would you be willing to work with our support engineers on this issue?  They can provide some next steps and work with you to restore video editing functionality.  

Leslie McKerchie

Hi Lucy,

Thanks for reaching out and letting us know that you're running into an issue with crashing as well.

I glanced back over the conversation here, and it seems that uninstalling/reinstalling worked for some and Simon worked with our support team to prevent his antivirus software from causing an issue.

Have you conducted any troubleshooting on your software yet? What version of Storyline are you currently using?

Linda Jordan

In our government organization I was able to locate and resolve this issue as follows:

Using Procmon, I could see that upon launching video edit, the file "encoder.exe"  would error "FILE LOCKED WITH ONLY READERS".

C:\Program Files (x86)\Articulate\Storyline 3\encoder.exe

This made sense (for us) since running the program as an admin also resolved the issue. Our users were unable to run the encoder.exe as a Windows user account. Since giving admin permissions to our Storyline users wasn't an option, white listing the encoder.exe file resolved the issue for all users.

I'm no programmer, but I believe Articulate can tweak their code to eliminate this issue.

I hope this is helpful to someone.

Linda

 

Ashley Terwilliger

Thanks, Linda for sharing those details and I'm happy you're back up and running. 

I haven't seen widespread reports, outside of this discussion, with the video editor crashing Storyline based on the computer permissions - but I can share the details with the team in case it helps with our investigations. 

instructional design

Since the new update the video editor is crashing SL so is unusable. but then the new update has caused so many issues - even what should be simple - copy and pasting text now crashes SL if there are 2 different text styles in one piece of text. 

Please please test your updates before releasing! We are customers not beta testers!

Ren Gomez

Hi Instructional Design,

I'm sorry to hear you're running into these issues with the video editor on the latest update! I'm not aware of any recent trends with that feature. 

  • Are you experiencing this in multiple files, or just one?

Our team would be happy to take a look and see if we can replicate the issue. Feel free to share your file using the link below.