Storyline is locked by another process

I need some help.  I was trying to publish the file to LMS and it crashed and closed by itself partway through.  I though I would try again, but I keep getting a message "The project "Storyline" is locked by another process"  when I try an open my Storyline 2 file.

I have rebooted my laptop and successfully opened different storyline files.

Any ideas on how to fix this without re-creating the whole project?

63 Replies
Crystal Horn

Hi there, Pamela, Debra, and David.  Really great conversation here - thanks for sharing information.

Pamela, I want to be sure that you're able to open and edit your project after discovering an issue with syncing to Google Drives.  Let me know if you still need help opening your project!

We do recommend saving your file locally and then backing up to your network locations to avoid issues with files locking up and network latency.  Tom from my team wrote an article on how to do this with a more efficient workflow.  The article is a bit dated, but the information is still valuable!

If there's anything else I can answer, I'll be here!

Richard Fouchaux

This still happens to me quite frequently when the file is on an external drive. Rebooting, nor different USB ports nor anything else I tried until finding this thread has worked... but so far I nearly always have an exact duplicate on a local drive, then "Save As" when I need to update the backup or take the EHD elsewhere. But occasionally I actually need to work on the project from elsewhere. Renaming the file worked for me just now and I thank you all. It's certainly 'odd' and does seem to affect quite a few people… aka 'bug', I think. I'm a happy AS360 convert with 10 years of Captivate behind me (v3.0) and I do hope you can get it sorted out. A minor nuisance, hardly a show-stopper as long as the simple renaming works for you. Cheers!

Mike Adamski

I've read that Articulate seems to think this may be related to a Windows issue locking the system. This may be entirely possible, yet this is the only piece of software I've ever used that has this issue, and it happens continually. With all due respect, this should be looked into further than "renaming a file" or "re-importing files into a new project."

Software should run efficiently within the OS it is designed for. The message may be generated from Windows, but the error is related to the software design. 

It would be like if you had a new car that keeps smoking after being driven over 2 hours, and the dealership telling you just to turn off the engine to let it cool down--there's a bigger issue here.

Richard Fouchaux

I don't want to leave any impression I'm unhappy with Storyline. I was a Captivate user for over 10 years. I'm a convert. I'm not shocked or daunted that it's still not perfect.

I've noticed one or two other things only AS360 does in Windows. When maximized, it can spontaneously resize its own window. When this happens pressing the maximize button or double-clicking the title bar first centers the window in the screen. You must then repeat that action to make it full screen. I've encountered no other application that requires the second click. Like the name-change thing, it's a nuisance, it's nobody's bug but Storyline's, and I fully expect it will be fixed some day.

In the last two updates I've noticed when I press Play to watch a layer it no longer stops when the layer timeline stops, it starts over at the top of the base slide, without audio. This I find to be a much bigger nuisance and I really hope it's fixed as soon as possible, preferably in the next update.

Eric Schaffer

Had the issue today after a lot of file and cloud moving yesterday by my IT department. I was able to just copy and move the file and it opened. Looking at the thread this issue has something to do with where the files are stored. Our company has the same issues with external drives so we went to cloud storage. I think Articulate needs to look at this and make sure cloud storage works. When I copied it and put it back on my laptop it works.

Thanks everybody for the great information. 

Leslie McKerchie

Hello Richard,

Thanks for sharing what you are running into.

I scrolled through your previous forum discussions and searched for a support case on the issues you're sharing, but I came up empty-handed.

With your permission, I'd like you to share your project file with our support engineers to investigate what's happening (1. the two-click full screen and 2. timeline starting over). You can share it privately by uploading it here. It will be deleted when troubleshooting is complete.

Richard Fouchaux

Thanks David. We have GIT, but I'm the only one here who's ever used it, and in this case we're talking about retrieving changes that were probably never committed. Once I've copy/pasted the file, and then opened the copy I "Save as..." to restore the filename continuity, and then also delete the copy.

So to be entirely clear, in Windows 10, when I get "locked by another process" message I:
1) close Storyline (and I'm not sure this is absolutely necessary)
2) select the file in the folder, right-click and Copy
3) Right-click and Paste the file into the same folder... "Copy of" is appended.
4) Open the copy, and immediately "Save as..." the original.
5) Delete the copy ASAP, to avoid confusion and folder bloat.

As several have noted, it's unusual software behaviour, apparently unique to Storyline. I'm not the one to say if it's a feature or a bug. ;-)

Richard Fouchaux

Sorry I didn't see your offer earlier, perhaps because I was away for part of the time, and then because an internal review of the project will result in quite a few changes. I think it sounds worth looking into anyway. I'll follow up (shortly) at the link you provided. Thanks, Leslie!